[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] boot issue

  • To: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Jon <jonr@xxxxxxxxxx>
  • Date: Sun, 12 Jun 2011 12:27:04 -0800
  • Delivery-date: Sun, 12 Jun 2011 13:28:44 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On Sun, 2011-06-12 at 00:01 -0400, Todd Deshane wrote:
> On Fri, Jun 10, 2011 at 8:16 AM, Ottà Ursinyi <oursinyi@xxxxxxxxx> wrote:
> > Hi There,
> >
> > I am beginer in xen and I faced with the following problem: I installed a
> > lucid as guest and it worked fine. But last week occurred a power cut and
> > the lucid did not start after we get the power back. I tried to start it
> > manually, but in the console I get this message:
> >
> > libudev: udev_monitor_new_from_netlink: error getting socket: Invalid
> > argument
> > mountall:mountall.c:3204: Assertion failed in main: udev_monitor =
> > udev_monitor_new_from_netlink (udev, "udev")
> > init: mountall main process (570) killed by ABRT signal
> > General error mounting filesystems.
> >
> > What can I do with this? How can I start again this guest?
> >
> You might be able to mount the guest disk image or partition outside
> of Xen in your dom0 and fix the file system manually,  then be sure to
> umount the image or partition before trying to boot the guest.
> Hope that helps.
> Thanks,
> Todd

Another idea would be to use an iso for a distro that has a recovery
method in the boot options, such as Fedora, as the disk. Then you boot
into recovery mode and mount the filesystem and fix it that way. This is
nice because it does all the work of mounting the partitions for you.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.