[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] easy way to break pygrub on oneiric amd64 dom0

  • To: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Mark Pryor <tlviewer@xxxxxxxxx>
  • Date: Sun, 11 Sep 2011 16:07:59 -0700 (PDT)
  • Delivery-date: Sun, 11 Sep 2011 16:09:13 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=X-YMail-OSG:Received:X-Mailer:Message-ID:Date:From:Reply-To:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=XXu7JwPET52DaAtl5/59PmInenT/EJq0EQxKJo7/Nn4D+GEUcuHfjLk1bNn6ufVaRKs/rtjw+PHjdZ4wIVwxnHbg4Rub3eOXy/r8zRhGWq/F6WcF63Lk8UFsZC+65pHfr4yb7LwZoMsk1tp+ZodVcmJieYJNq5A8U4Mkqba1Za8=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


Want to break pygrub on latest ubuntu dom0? Here's how: clobber this symlink:

    /lib64 -> lib

Here's what happened.

I had xen 4.1.1 from source working on oneiric (alpha) 11.10 dom0, using kernel 
3.0 from repos. 
The xen was built on a natty 11.04 install and the 11.10 dom0 install was 
debootstrapped while in 11.104.
This process was easy and smooth and the dom0 worked with no surprises.

When the beta upgrade (apt-get upgrade) was done in late Auguest pygrub 
suddenly broke. I thought the trouble was a package regression. I tried some 
downgrades, especially of the python changes.
None of that helped.

After a week, I gave up and decided that the beta release was enough reason to 
reinstall. The problem still existed.
After comparing the list of / (root) and /usr, I noticed the missing symlink.

I still don't understand how the symlink broke (twice). It's not important for 
now, but I will be happy when I figure that out.

If you can't get pygrub to work, check the above symlink for an easy fix.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.