[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Domu has no disks

  • To: "XEN Mailing List" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Barry Kolts" <bhkolts@xxxxxxxxxxx>
  • Date: Tue, 11 Oct 2011 23:15:13 -0500
  • Delivery-date: Tue, 11 Oct 2011 21:16:29 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

----- Original Message ----- From: "Mark Pryor" <tlviewer@xxxxxxxxx>
To: "Barry Kolts" <bhkolts@xxxxxxxxxxx>
Cc: <xen-users@xxxxxxxxxxxxxxxxxxx>
Sent: Tuesday, October 11, 2011 7:26 PM
Subject: Re: [Xen-users] Domu has no disks

----- Original Message -----
From: Barry Kolts <bhkolts@xxxxxxxxxxx>
To: XEN Mailing List <xen-users@xxxxxxxxxxxxxxxxxxx>
Sent: Tuesday, October 11, 2011 5:02 PM
Subject: [Xen-users] Domu has no disks


This is my first post to the list and I am new to Xen, so please excuse my ignorance.

I have Xen 4.0 running on Debian Squeeze with Squeeze as dom0. I am trying to install Ubuntu Lucid 10.04 as a guest. I am using the install cd iso. I think I should be able to do this based on this quote from http://wiki.xensource.com/xenwiki/XenOverview. From the 'Installing new Paravirtual (PV) guests' section, 'Ubuntu 10.04 ("Lucid Lynx") installer can be booted as a Xen PV guest and installed easily that way. '.

The problem is once the Ubuntu installer starts it cannot find the cdrom. Also if I use the net-install method, the installer can't find the virtual disk to install to. So my problem is not getting domu to boot but not having any disks once it does.

My domu configuration file is based on the xmexample1 configuration that was packaged with Xen. Rather than posting the whole file here are the changes I made:

kernel = "/etc/xen/install_kernels/cd-installer/vmlinuz"
ramdisk = "/etc/xen/install_kernels/cd-installer/initrd.gz"
memory = 512
name = "Lucid-server-install"
disk = [ 'file:/home/barry/iso/ubuntu-10.04.3-server-amd64.iso,xvdc:cdrom,r',
'tap:aio:/xen-vm-fs/lucid-vm-disk,xvda,w' ]
root = "/dev/cdrom ro"

The kernel and initrd.gz are copied of the cd iso. In the disk statement I have tried hdc, hda, sda, sdc to no avail. I have Googled, searched this list, the debian list, Ubuntu documentation and the Xen.org documentation and not found the answer. Can anyone spot where I've gone wrong? Please ask for more information or suggest how I can debug this problem. One more piece of information, this machine does not have a virtualization process so paravirtual is a must.

Thanks in advance for any help


You want to use the CD ISO as source, but not as boot object.

What I did is mount the ISO in a webroot (/var/www/), copy off the netboot vmlinuz and initrd.img and them as targets to
xm create (kernel/ramdisk).

Now you are booting into a PV install using xm.

THis works very well and is fast.


Thanks for your reply Mark,

OK so now I have changed my 'kernel =' to point to the net install kernel
and the 'ramdisk =' to point to the net-install initrd.gz which I copied of
the iso. I mounted the iso on my web server. When the installer ask me what
Ubuntu mirror to use, I specify which is where
the iso is mounted. The installer comes back with 'invalid release file'. I
tried several directories that had release files and still no luck.
I'm really missing something here, but I don't know what.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.