[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xcp : vm installation

  • To: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Valerio De Rosa <valesmn@xxxxxxxx>
  • Date: Mon, 13 Feb 2012 10:04:39 +0000 (GMT)
  • Cc: Marco De Luca <only_metal@xxxxxxx>
  • Delivery-date: Mon, 13 Feb 2012 10:06:53 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.it; h=X-YMail-OSG:Received:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:Cc:MIME-Version:Content-Type; b=l5P5CJf6C3SyOcOXU1UnAJ++GUXU6GHnWDVk51tb7SQgPdyEBldG2pMKv8GpBhhbhcRHsFM4kCHw3KKZKpiUAJzoEuL//RmhtkWdzgFJ4Df/jn3DTm+4MnAbOUhpihbv/DWtepfRl7WsQZCUZnejB/XmwJ/jQivqeMDqXKQhOj0=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hello there,
i am trying to create a VM using xcp on my system, with os Ubuntu 11.10. Iâve got 3 server on my testbed and in the near future i am going to try a VM live migration from a server to another, but actually I am having few problems.
 The first one : i installed the xcp-xapi on 2 of my servers, and when i give the command

#xe template-list

One of the server gives me the list, while the other one doesnât. Itâs very strange, since I made the same installation steps on both machines.
Following the guide at http://xen.org/files/XenCloud/installation.pdf ,  and after typed the command:

 # update-rc.d porta default 21 19 (instead of chkconfig portmap on)

I find that the  xcp-xapi libs are not running anymore, living the answer âserver not foundâ. Searching on the web it look like there should be a conflict between xcp and apache2http, both using port 80 for communication with localhost.
After stopping apache2 with a  âservice apache2 stopâ, the xcp-xapi libs can be restarted, and looks like they are working properly.

I try then to create a storage to prepare my vm installation:

 #xe sr-create name-label=centos6 type=iso device-config:location=/.../centos6 device-config:legacy_mode=true content-type=iso

Then I tried installing a vm with:

#xe vm-install new-name-label=centos6bob sr-name-label=centos6 template=CentOS\ 6\ \(32-bit\)
You attempted an operation that was not allowed.
reason: Cannot copy a VM's disks to an ISO SR

getting the error up here.
I tried also changing the sr-type with ânfsâ, but the error is nearly the same. I think I am making some wrong step, but I canât find which oneâhope someone can help.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.