[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xcp : vm installation

  • To: Scott Damron <sdamron@xxxxxxxxx>
  • From: Valerio De Rosa <valesmn@xxxxxxxx>
  • Date: Mon, 13 Feb 2012 14:14:48 +0000 (GMT)
  • Cc: Marco De Luca <only_metal@xxxxxxx>, "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • Delivery-date: Mon, 13 Feb 2012 14:15:54 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.it; h=X-YMail-OSG:Received:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=ewiMsUQGE7JHRDmRW+OdAwbtvGr9k+hXWt8C1wkVkoTI2VSL4RGOXdd8aPmHrpYngqsOr2ipakc1UqW9InJqXe7cYiUqslXEr9yUTLTnTFMSoEyMHK4hnkvrFVywKY0SFrwiQg47rts7bMemiCmbUCGuXVhX/d21X2P9nXUDBXw=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I think I am really having problems understanding how I should proceed, Could you be so kind to give some tips?
On my server, I have not a cd-rom, but a virtual media(I mount images on the server using hp ilo, from another host).That means that I can find a mounted image not in /dev/ but somewhere else I have not found exactly. Said that, I cannot understand why, following this guyâs steps (http://xen.1045712.n5.nabble.com/Docs-How-to-create-and-install-CentOS-PVMs-with-xe-CLI-on-XCP-1-1-td4937495.html) I encounter always the same error, the one you were referring in your answer.

Da: Scott Damron <sdamron@xxxxxxxxx>
A: Valerio De Rosa <valesmn@xxxxxxxx>
Cc: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>; Marco De Luca <only_metal@xxxxxxx>
Inviato: Lunedà 13 Febbraio 2012 13:30
Oggetto: Re: [Xen-users] xcp : vm installation

In the case of the last error, it is telling you exactly what the
issue is, you can not store a disk image (a virtual hard drive you are
creating in order to run a virtual machine) on the same SR as your ISO

On Mon, Feb 13, 2012 at 4:04 AM, Valerio De Rosa <valesmn@xxxxxxxx> wrote:
> Hello there,
> i am trying to create a VM using xcp on my system, with os Ubuntu 11.10.
> Iâve got 3 server on my testbed and in the near future i am going to try a
> VM live migration from a server to another, but actually I am having few
> problems.
>  The first one : i installed the xcp-xapi on 2 of my servers, and when i
> give the command
> #xe template-list
> One of the server gives me the list, while the other one doesnât. Itâs very
> strange, since I made the same installation steps on both machines.
> Following the guide at http://xen.org/files/XenCloud/installation.pdf ,  and
> after typed the command:
>  # update-rc.d porta default 21 19 (instead of chkconfig portmap on)
> I find that the  xcp-xapi libs are not running anymore, living the answer
> âserver not foundâ. Searching on the web it look like there should be a
> conflict between xcp and apache2http, both using port 80 for communication
> with localhost.
> After stopping apache2 with a  âservice apache2 stopâ, the xcp-xapi libs can
> be restarted, and looks like they are working properly.
> I try then to create a storage to prepare my vm installation:
>  #xe sr-create name-label=centos6 type=iso
> device-config:location=/.../centos6 device-config:legacy_mode=true
> content-type=iso
> Then I tried installing a vm with:
> #xe vm-install new-name-label=centos6bob sr-name-label=centos6
> template=CentOS\ 6\ \(32-bit\)
> You attempted an operation that was not allowed.
> reason: Cannot copy a VM's disks to an ISO SR
> getting the error up here.
> I tried also changing the sr-type with ânfsâ, but the error is nearly the
> same. I think I am making some wrong step, but I canât find which oneâhope
> someone can help.
> Regards,Valerio.
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.