[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xenconsole: Could not read tty from store: No such file or directory

On Tue, Mar 20, 2012 at 12:44 PM, Ian Campbell <Ian.Campbell@xxxxxxxxxx> wrote:
On Tue, 2012-03-20 at 17:20 +0000, Su Zhang wrote:

> After I rebooted &&deleted&& reinstalled domU, an interesting thing
> happened, the error seems to have gone away, instead, there is a long
> script following the command line, but it just stuck there. nothing
> can be done here, here is the running script:

> [root@XenTester su]# xm console cent5

This is the console log of the domain, which is good because it means
this problem is solved.

I expect the installer is running on the VNC console and not this serial
console. Not sure how you convince CentOS (esp, using virt-install) to
use the serial console for install, google perhaps?

Do you mean if I just leave it stuck here and connect to VNC manually then I can still get it around?  So that I can do the rest over VNC?

> Thanks a lot. I've already re-configured the firewall rules to allow
> 5900-6000 [both in and out]. The command "vncviewer localhost:5901"
> can bring a VNC window to me.

Great what is on the VNC window? Do you see the RH installer?

I guess so, it starts with language selection and followed by network configuration. But I cannot pass through the network (IP) configuration.
It doesn't allow me to go forward but no error info is displayed. Do you think it is because the VNC hasn't been setup appropriately? or the guest OS kernel issue?



Su Zhang
Ph.D Candidate
Computing and Information Sciences
Kansas State University
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.