[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Xen-devel] Cannot Start Linux Paravirtualized (PV) Guests with Xen 4.2-unstable

On 30/03/2012 13:56, Sergey Zhukov wrote:
On Fri, 2012-03-30 at 13:07 +0800, Teo En Ming (Zhang Enming) wrote:
On 30/03/2012 05:09, Sergey Zhukov wrote:
3) When I was installing Ubuntu 12.04 Beta 1 Precise Pangolin amd64 as
a HVM domU in either Xen 4.1.3-rc1-pre or Xen 4.2-unstable, it hanged
at COPYING FILES during installation. Hence I have to abort the HVM
domU installation. Disk I/O performance is very poor.
4) Disk I/O performance is very poor with Debian 6.0 Squeeze PV domU
in Xen 4.2-unstable and with Fedora 16 x86-64 PV domU in Xen
4.1.3-rc1-pre. The mouse cursor movement in both Fedora 16 and Debian
6.0 Squeeze PV domU is very sluggish and unresponsive. It also takes a
long time to format filesystems and install packages in PV domU during
OS installation. What causes the performance penalty in disk I/O?
5) Disk I/O performance is also very poor with Ubuntu 12.04 Beta 1 HVM
domU installation. Formatting filesystems and copying files during
installation take a long time. Mouse cursor movement is also very
I installed Ubuntu 12.04 beta server (AMD 64) and xen hypervisor from
ubuntu xen packages (v4.1).
Then I installed Ubuntu 10.04 server as PV DomU and Ubuntu 10.04 desktop
as HVM DomU.
I could not enable IO virtualization, because iommu=1 and iommu=verbose
parameters seem to be not working.
Dear Sergey Zhukou,

Thank you very much for your reply.

I did not have to specify IOMMU=1 and IOMMU=verbose in my multiboot
xen.gz command line in GRUB2. IOMMU is enabled by default in Xen

sudo xl dmesg | grep 'I/O Virtualisation'

(XEN) I/O Virtualisation Enabled

When I run tests for my specific software I found, that in Ubuntu 10.04
HVM DomU there are too many interrupts when dealing with network.
Processor took about 50%si. I did not test disk IO, but think the
picture should be the same.
When I am installing Ubuntu 12.04 Beta 1 HVM domU, the network
connection gets disconnected and re-connected many times. Did your
installation hanged at copying files while installing Ubuntu 10.04 HVM domU?

No, installation has processed smoothly, after 15 minutes I had the
system installed.

But I found solution, which works perfect for me. I installed Ubuntu
12.04 desktop beta (i386) as PVHVM DomU. It installed without hangs and
it works very fast with network and disk.
I do not know what is PVHVM, I only know PV domU and HVM domU separately.

Just an option xen_platform_pci='1' in HVM config file before
installation of distributive. There is a wiki

Also, I would like to know, how to enable verbose logs for iommu,
because xm dmesg does not show me any information about VT-d. I have the
(XEN) Command line: placeholder iommu=verbose
in the dmesg logs, but still not got verbose logs...
I do not know how to enable verbose logs for IOMMU.

Have you tried "sudo xl dmesg | grep VT-d"?
Yes, that the thing I told about, that I don't have any lines about
VT-d. This is my full log

(XEN) Bootloader: GRUB 1.99-18ubuntu1
(XEN) Command line: placeholder iommu=verbose
(XEN) Video information:
(XEN)  VGA is text mode 80x25, font 8x16
(XEN)  VBE/DDC methods: none; EDID transfer time: 0 seconds
(XEN)  EDID info not retrieved because no DDC retrieval method detected
(XEN) Disc information:
(XEN)  Found 1 MBR signatures
(XEN)  Found 1 EDD information structures
(XEN) Xen-e820 RAM map:
(XEN)  0000000000000000 - 000000000009ec00 (usable)
(XEN)  000000000009ec00 - 00000000000a0000 (reserved)
(XEN)  00000000000e0000 - 0000000000100000 (reserved)
(XEN)  0000000000100000 - 0000000020000000 (usable)
(XEN)  0000000020000000 - 0000000020200000 (reserved)
(XEN)  0000000020200000 - 0000000040000000 (usable)
(XEN)  0000000040000000 - 0000000040200000 (reserved)
(XEN)  0000000040200000 - 00000000babc3000 (usable)
(XEN)  00000000babc3000 - 00000000bac0c000 (ACPI NVS)
(XEN)  00000000bac0c000 - 00000000bacc4000 (reserved)
(XEN)  00000000bacc4000 - 00000000baccc000 (ACPI data)
(XEN)  00000000baccc000 - 00000000bacf3000 (reserved)
(XEN)  00000000bacf3000 - 00000000bacf5000 (usable)
(XEN)  00000000bacf5000 - 00000000bad05000 (reserved)
(XEN)  00000000bad05000 - 00000000bad13000 (ACPI NVS)
(XEN)  00000000bad13000 - 00000000bad38000 (reserved)
(XEN)  00000000bad38000 - 00000000bad7b000 (ACPI NVS)
(XEN)  00000000bad7b000 - 00000000bb000000 (usable)
(XEN)  00000000bb800000 - 00000000bfa00000 (reserved)
(XEN)  00000000fed1c000 - 00000000fed40000 (reserved)
(XEN)  00000000ff000000 - 0000000100000000 (reserved)
(XEN)  0000000100000000 - 000000043fe00000 (usable)
(XEN) ACPI: RSDP 000F0450, 0024 (r2 ALASKA)
(XEN) ACPI: XSDT BACC4070, 005C (r1 ALASKA    A M I  1072009 AMI
(XEN) ACPI: FACP BACCB4A0, 00F4 (r4 ALASKA    A M I  1072009 AMI
(XEN) ACPI: DSDT BACC4158, 7348 (r2 ALASKA    A M I       15 INTL
(XEN) ACPI: APIC BACCB598, 0072 (r3 ALASKA    A M I  1072009 AMI
(XEN) ACPI: SSDT BACCB610, 0102 (r1 AMICPU     PROC        1 MSFT
(XEN) ACPI: MCFG BACCB718, 003C (r1 ALASKA    A M I  1072009 MSFT
(XEN) ACPI: HPET BACCB758, 0038 (r1 ALASKA    A M I  1072009 AMI.
(XEN) ACPI: ASF! BACCB790, 00A0 (r32 INTEL       HCG        1 TFSM
(XEN) ACPI: BGRT BACCB830, 003C (r0 ALASKA    A M I  1072009 AMI
(XEN) System RAM: 16295MB (16687008kB)
(XEN) Domain heap initialised
(XEN) ACPI: 32/64X FACS address mismatch in FADT -
bad0af80/0000000000000000, using 32
(XEN) Processor #0 6:10 APIC version 21
(XEN) Processor #2 6:10 APIC version 21
(XEN) Processor #4 6:10 APIC version 21
(XEN) Processor #6 6:10 APIC version 21
(XEN) IOAPIC[0]: apic_id 0, version 32, address 0xfec00000, GSI 0-23
(XEN) Enabling APIC mode:  Flat.  Using 1 I/O APICs
(XEN) Table is not found!
(XEN) Not enabling x2APIC: depends on iommu_supports_eim.
(XEN) Using scheduler: SMP Credit Scheduler (credit)
(XEN) Detected 3292.655 MHz processor.
(XEN) Initing memory sharing.
(XEN) I/O virtualisation disabled
(XEN) Enabled directed EOI with ioapic_ack_old on!
(XEN)  ->  Using old ACK method
(XEN) Platform timer is 14.318MHz HPET
(XEN) Allocated console ring of 16 KiB.
(XEN) VMX: Supported advanced features:
(XEN)  - APIC MMIO access virtualisation
(XEN)  - APIC TPR shadow
(XEN)  - Extended Page Tables (EPT)
(XEN)  - Virtual-Processor Identifiers (VPID)
(XEN)  - Virtual NMI
(XEN)  - MSR direct-access bitmap
(XEN)  - Unrestricted Guest
(XEN) EPT supports 2MB super page.
(XEN) HVM: ASIDs enabled.
(XEN) HVM: VMX enabled
(XEN) HVM: Hardware Assisted Paging detected.
(XEN) Brought up 4 CPUs
(XEN)  Xen  kernel: 64-bit, lsb, compat32
(XEN)  Dom0 kernel: 64-bit, PAE, lsb, paddr 0x1000000 ->  0x2060000
(XEN)  Dom0 alloc.:   0000000428000000->0000000430000000 (4049834 pages
to be allocated)
(XEN)  Init. ramdisk: 000000043d6e6000->000000043fdff800
(XEN)  Loaded kernel: ffffffff81000000->ffffffff82060000
(XEN)  Init. ramdisk: ffffffff82060000->ffffffff84779800
(XEN)  Phys-Mach map: ffffffff8477a000->ffffffff866b3620
(XEN)  Start info:    ffffffff866b4000->ffffffff866b44b4
(XEN)  Page tables:   ffffffff866b5000->ffffffff866ec000
(XEN)  Boot stack:    ffffffff866ec000->ffffffff866ed000
(XEN)  TOTAL:         ffffffff80000000->ffffffff86800000
(XEN)  ENTRY ADDRESS: ffffffff81cfc200
(XEN) Dom0 has maximum 4 VCPUs
(XEN) Scrubbing Free RAM: .done.
(XEN) Xen trace buffers: disabled
(XEN) Std. Loglevel: Errors and warnings
(XEN) Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
(XEN) Xen is relinquishing VGA console.
(XEN) *** Serial input ->  DOM0 (type 'CTRL-a' three times to switch
input to Xen)
(XEN) Freed 220kB init memory.
(XEN) physdev.c:155: dom0: wrong map_pirq type 3
(XEN) irq.c:1828: dom4: pirq 55 or emuirq 23 already mapped
(XEN) irq.c:1828: dom5: pirq 55 or emuirq 23 already mapped

Sergey Zhukov

Dear Sergey Zhukov,

From the above Xen kernel message logs, it appears that your computer hardware does not support VT-d or VT-d was not enabled in your Xen installation.

Thank you very much.

Yours sincerely,

Mr. Teo En Ming (Zhang Enming)

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.