[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XCP 1.5 beta and Gentoo


I don't know too much about XCP (or anything beyond the Xen.org stuff
anyways) the following information could help alot:

If booting in HVM mode (you are talking about CDROMs so I guess so)
then a screenshot of the VNC session or just a consise summary of the
output (for instance "Not bootable device found ". etc)
Output of any relevant logs in /var/log/xen/ specifically the xl
domain and qemu dm logs.
Domain config file (or settings.. not sure what XCP does here)

That should be enough to get us started.


On 31 March 2012 22:50, John F. Acree <john@xxxxxxxxxxxx> wrote:
> Hi Everyone,
> I am new to Xen, researching whether we can use it for internal development
> systems and server virtualization to replace our current solution.
> Gentoo is the guest linux os that we use and I have been having some trouble
> getting a new Gentoo guest installed.
> Everything works fine with XCP 1.1, I really like it.  so I thought I would
> try the 1.5 beta.  Here is the trouble I run into.  Oh, I am using xencenter
> to create the virtual machines.
> * Create a new virtual machine, select the other install media template.
> * Select the gentoo-install-minimum-amd64 iso from iso repository.
> * Leave everything else defaults
> * Add 1 drive, 8gb.
> * Uncheck the startup virtual machine checkbox on the last step of the
> wizard.(This is important due to some timing in the gentoo iso boot process,
> it tries to boot from disk if no user input received in 15 seconds and it
> would take longer then that for the console to refresh so I could intervene)
> * Go to the console
> * Click start this virtual machine
> * When prompted, specify the gentoo kernel.
> These steps work great with XCP 1.1, the OS detects it is running in a xenU
> environment, xvda is present.  But when I try to repeat these steps with XCP
> 1.5beta, the cd can not be found and the boot process stops before it really
> gets started.
> My solution was to install XCP 1.1, install the virtual machine, get it
> running with xvda, hvc0, etc.  Then use the XCP 1.5 beta disk to upgrade the
> server.  It worked, but I am hoping there is something I can adjust so I can
> setup another server and use 1.5 beta from the start.  Another option is
> using a different linux os to get the boot started, and then going through
> the Gentoo install process.  Again, an option I would like to avoid if
> possible.
> Let me know if I am asking in the wrong place or if I overlooked some
> information in the archives.  And if there is any more information I could
> provide that would be helpful.
> Other then this issue, everything has been working nice.  I expect there is
> still quite a learning curve to working with Xen.
> Thanks,
> John
> --
> John F. Acree
> ideacode, Inc.
> www.ideacode.com / (main) +1 919 341 5170 / (fax) +1 919 521 4100
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxx
> http://lists.xen.org/xen-users

Founder | Director | VP Research
Orion Virtualisation Solutions | www.orionvm.com.au | Phone: 1300 56
99 52 | Mobile: 0428 754 846

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.