[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XCP 1.5 beta and Gentoo

  • To: xen-users@xxxxxxxxxxxxx
  • From: "John F. Acree" <john@xxxxxxxxxxxx>
  • Date: Sun, 08 Apr 2012 06:45:21 -0400
  • Delivery-date: Sun, 08 Apr 2012 10:47:07 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>


I am attaching screenshots of the boot process.
Here is the xe vm-param-list output for the vm(kinda long):
uuid ( RO)                          : 30bae3dd-1c3c-840c-2e3f-8163b4346158
                    name-label ( RW): Test Virtual Machine
              name-description ( RW):
                  user-version ( RW): 1
                 is-a-template ( RW): false
                 is-a-snapshot ( RO): false
                   snapshot-of ( RO): <not in database>
                     snapshots ( RO):
                 snapshot-time ( RO): 19700101T00:00:00Z
                 snapshot-info ( RO):
                        parent ( RO): <not in database>
                      children ( RO):
             is-control-domain ( RO): false
                   power-state ( RO): running
                 memory-actual ( RO): 268402688
                 memory-target ( RO): 268435456
               memory-overhead ( RO): 5242880
             memory-static-max ( RW): 268435456
            memory-dynamic-max ( RW): 268435456
            memory-dynamic-min ( RW): 268435456
             memory-static-min ( RW): 134217728
              suspend-VDI-uuid ( RW): <not in database>
               suspend-SR-uuid ( RW): <not in database>
                  VCPUs-params (MRW):
                     VCPUs-max ( RW): 1
              VCPUs-at-startup ( RW): 1
        actions-after-shutdown ( RW): Destroy
          actions-after-reboot ( RW): Restart
           actions-after-crash ( RW): Restart
                 console-uuids (SRO): 7549b9f2-2025-49a6-2958-b89e1b0ec72e
platform (MRW): timeoffset: 0; nx: false; acpi: true; apic: true; pae: true; viridian: true allowed-operations (SRO): changing_dynamic_range; changing_VCPUs_live; hard_reboot; hard_shutdown; clean_reboot; clean_shutdown; pause; snapshot
            current-operations (SRO):
            blocked-operations (MRW):
           allowed-VBD-devices (SRO): 1; 2
           allowed-VIF-devices (SRO): 1; 2; 3
                possible-hosts ( RO):
               HVM-boot-policy ( RW): BIOS order
               HVM-boot-params (MRW): order: dc
         HVM-shadow-multiplier ( RW): 1.000
                     PV-kernel ( RW):
                    PV-ramdisk ( RW):
                       PV-args ( RW):
                PV-legacy-args ( RW):
                 PV-bootloader ( RW):
            PV-bootloader-args ( RW):
last-boot-CPU-flags ( RO): features: 179ae3bf-bfebfbff-00000001-28100800; vendor: GenuineIntel last-boot-record ( RO): '('struct' ('uuid' '30bae3dd-1c3c-840c-2e3f-8163b4346158') ('allowed_operations' ('array')) ('current_operations' ('struct' ('OpaqueRef:ee7002ce-607e-6a35-2837-b83a0aa838d5' 'start'))) ('power_state' 'Halted') ('name_label' 'Test Virtual Machine') ('name_description' '') ('user_version' '1') ('is_a_template' ('boolean' '0')) ('suspend_VDI' 'OpaqueRef:NULL') ('resident_on' 'OpaqueRef:NULL') ('affinity' 'OpaqueRef:8f00b1af-6189-3092-e793-1f5c39a1e90c') ('memory_overhead' '5242880') ('memory_target' '268435456') ('memory_static_max' '268435456') ('memory_dynamic_max' '268435456') ('memory_dynamic_min' '268435456') ('memory_static_min' '134217728') ('VCPUs_params' ('struct')) ('VCPUs_max' '1') ('VCPUs_at_startup' '1') ('actions_after_shutdown' 'destroy') ('actions_after_reboot' 'restart') ('actions_after_crash' 'restart') ('consoles' ('array')) ('VIFs' ('array' 'OpaqueRef:cab3403c-ecee-3c41-2ebd-191e12360b93')) ('VBDs' ('array' 'OpaqueRef:5ce00c29-ce8c-5d59-4a99-66c46839714e' 'OpaqueRef:4c8668d0-97fb-feec-f9fa-a50b4dffeb44')) ('crash_dumps' ('array')) ('VTPMs' ('array')) ('PV_bootloader' '') ('PV_kernel' '') ('PV_ramdisk' '') ('PV_args' '') ('PV_bootloader_args' '') ('PV_legacy_args' '') ('HVM_boot_policy' 'BIOS order') ('HVM_boot_params' ('struct' ('order' 'dc'))) ('HVM_shadow_multiplier' ('double' '1')) ('platform' ('struct' ('timeoffset' '0') ('nx' 'false') ('acpi' 'true') ('apic' 'true') ('pae' 'true') ('viridian' 'true'))) ('PCI_bus' '') ('other_config' ('struct' ('last_shutdown_time' '20120331T12:47:58Z') ('last_shutdown_action' 'Destroy') ('last_shutdown_initiator' 'external') ('last_shutdown_reason' 'halted') ('mac_seed' '7aeb3116-63f7-c961-35e6-406a3e1ce839') ('install-methods' 'cdrom'))) ('domid' '-1') ('domarch' 'hvm') ('last_boot_CPU_flags' ('struct' ('features' '179ae3bf-bfebfbff-00000001-28100800') ('vendor' 'GenuineIntel'))) ('is_control_domain' ('boolean' '0')) ('metrics' 'OpaqueRef:5d850bf7-448c-a51d-7062-b71e03ea6068') ('guest_metrics' 'OpaqueRef:NULL') ('last_booted_record' '') ('recommendations' '<restrictions><restriction field=\"memory-static-max\" max=\"137438953472\" /><restriction field=\"vcpus-max\" max=\"16\" /><restriction property=\"number-of-vbds\" max=\"7\" /><restriction property=\"number-of-vifs\" max=\"7\" /></restrictions>') ('xenstore_data' ('struct')) ('ha_always_run' ('boolean' '0')) ('ha_restart_priority' '') ('is_a_snapshot' ('boolean' '0')) ('snapshot_of' 'OpaqueRef:NULL') ('snapshots' ('array')) ('snapshot_time' ('dateTime.iso8601' '19700101T00:00:00Z')) ('transportable_snapshot_id' '') ('blobs' ('struct')) ('tags' ('array')) ('blocked_operations' ('struct')) ('snapshot_info' ('struct')) ('snapshot_metadata' '') ('parent' 'OpaqueRef:NULL') ('children' ('array')) ('bios_strings' ('struct')) ('protection_policy' 'OpaqueRef:NULL') ('is_snapshot_from_vmpp' ('boolean' '0')) ('appliance' 'OpaqueRef:NULL') ('start_delay' '0') ('shutdown_delay' '0') ('order' '0') ('VGPUs' ('array')) ('attached_PCIs' ('array')) ('suspend_SR' 'OpaqueRef:NULL') ('version' '0'))'
                   resident-on ( RO): cdfffa23-9126-4b5c-9f63-d3a56eb33e2f
                      affinity ( RW): cdfffa23-9126-4b5c-9f63-d3a56eb33e2f
other-config (MRW): last_shutdown_time: 20120331T12:47:58Z; last_shutdown_action: Destroy; last_shutdown_initiator: external; last_shutdown_reason: halted; mac_seed: 7aeb3116-63f7-c961-35e6-406a3e1ce839; install-methods: cdrom
                        dom-id ( RO): 2
recommendations ( RO): <restrictions><restriction field="memory-static-max" max="137438953472" /><restriction field="vcpus-max" max="16" /><restriction property="number-of-vbds" max="7" /><restriction property="number-of-vifs" max="7" /></restrictions>
                 xenstore-data (MRW):
    ha-always-run ( RW) [DEPRECATED]: false
           ha-restart-priority ( RW):
                         blobs ( RO):
                    start-time ( RO): 20120408T10:26:40Z
                  install-time ( RO): 20120331T11:29:29Z
                  VCPUs-number ( RO): 1
             VCPUs-utilisation (MRO): 0: 0.003
                    os-version (MRO): <not in database>
            PV-drivers-version (MRO): <not in database>
         PV-drivers-up-to-date ( RO): <not in database>
                        memory (MRO): <not in database>
                         disks (MRO): <not in database>
                      networks (MRO): <not in database>
                         other (MRO): <not in database>
                          live ( RO): <not in database>
    guest-metrics-last-updated ( RO): <not in database>
                   cooperative ( RO): true
             protection-policy ( RW): <not in database>
         is-snapshot-from-vmpp ( RO): false
                          tags (SRW):
                     appliance ( RW): <not in database>
                   start-delay ( RW): 0
                shutdown-delay ( RW): 0
                         order ( RW): 0
                       version ( RO): 0
I have no idea where xcp keeps config files, so the vm-param-list is as close as I could find so far. And /var/log/messages has some output, I did not see anything helpful there though.



I don't know too much about XCP (or anything beyond the Xen.org stuff
anyways) the following information could help alot:

If booting in HVM mode (you are talking about CDROMs so I guess so)
then a screenshot of the VNC session or just a consise summary of the
output (for instance "Not bootable device found ". etc)
Output of any relevant logs in /var/log/xen/ specifically the xl
domain and qemu dm logs.
Domain config file (or settings.. not sure what XCP does here)

That should be enough to get us started.


On 31 March 2012 22:50, John F. Acree<john@xxxxxxxxxxxx>  wrote:
Hi Everyone,

I am new to Xen, researching whether we can use it for internal development
systems and server virtualization to replace our current solution.

Gentoo is the guest linux os that we use and I have been having some trouble
getting a new Gentoo guest installed.

Everything works fine with XCP 1.1, I really like it.  so I thought I would
try the 1.5 beta.  Here is the trouble I run into.  Oh, I am using xencenter
to create the virtual machines.

* Create a new virtual machine, select the other install media template.
* Select the gentoo-install-minimum-amd64 iso from iso repository.
* Leave everything else defaults
* Add 1 drive, 8gb.
* Uncheck the startup virtual machine checkbox on the last step of the
wizard.(This is important due to some timing in the gentoo iso boot process,
it tries to boot from disk if no user input received in 15 seconds and it
would take longer then that for the console to refresh so I could intervene)
* Go to the console
* Click start this virtual machine
* When prompted, specify the gentoo kernel.

These steps work great with XCP 1.1, the OS detects it is running in a xenU
environment, xvda is present.  But when I try to repeat these steps with XCP
1.5beta, the cd can not be found and the boot process stops before it really
gets started.

My solution was to install XCP 1.1, install the virtual machine, get it
running with xvda, hvc0, etc.  Then use the XCP 1.5 beta disk to upgrade the
server.  It worked, but I am hoping there is something I can adjust so I can
setup another server and use 1.5 beta from the start.  Another option is
using a different linux os to get the boot started, and then going through
the Gentoo install process.  Again, an option I would like to avoid if

Let me know if I am asking in the wrong place or if I overlooked some
information in the archives.  And if there is any more information I could
provide that would be helpful.

Other then this issue, everything has been working nice.  I expect there is
still quite a learning curve to working with Xen.

John F. Acree
ideacode, Inc.
www.ideacode.com / (main) +1 919 341 5170 / (fax) +1 919 521 4100


Xen-users mailing list

John F. Acree
ideacode, Inc.
www.ideacode.com / (main) +1 919 341 5170 / (fax) +1 919 521 4100


Attachment: Image2.png
Description: PNG image

Attachment: Image3.png
Description: PNG image

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.