[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Unable to boot installation ISO


this is the test I've just done for you.
3.3.0-gentoo kernel x86_64

domU installation:
ISO image: install-amd64-minimal-20120216.iso
I see you used a physical device. It should not be different.

I create the filesystem image using dd:
dd if=/dev/zero of=gentoo.img bs=1024k count=1 seek=15360

So, now I have three files in my domU directory:
gentoo.cfg  gentoo.img  install-amd64-minimal-20120216.iso

And this is the content of gentoo.cfg:
kernel = "/usr/lib/xen/boot/hvmloader"
memory = 1024
shadow_memory = 8
name = "gentoo"
vif = [ 'type=ioemu, mac=00:16:3e:00:00:02, bridge=xenbr0' ]
acpi = 1
apic = 1
disk = [ 'file:/path/to/gentoo.img,hda,w',
'file:/path/to/install-amd64-minimal-20120216.iso,hdc:cdrom,r' ]


Then I do xl create gentoo.cfg
xl vncviewer gentoo

(in this case vnc crashes - I didn't understand why yet - and
I have to re-run xl vncviewer gentoo)

and I can access to the minimal live gentoo and proceed with
the domU installation



On 4 April 2012 17:57, John F. Acree <john@xxxxxxxxxxxx> wrote:
> The gentoo minimal cd worked fine for me with xcp1.1, which I think is
> running the xen-3 series. ÂIt was only on xcp1.5 that I ran into problems
> getting it to be bootable, which I think runs the xen-4 series.
> I have no idea what the difference is between the two. ÂBut as soon as I get
> the chance I will take a screenshot of the boot process when it fails, and
> include the vm-param-list output for that vm.
> Maybe something has changed in the way the cdrom is handled or reported?
> John
>> Ok, to make a follow up on my original email, I tried linux rescue CD
>> (systemrecue cd) and it booted. I saw that it dosent (or dosent appear
>> to) support native Xen frontend driver so sees the cdrom in HVM.
>> the gentoo seems to support native xen drivers (when booting, I can see
>> the disk with xvda : xvda1, xvda2, etc)
>> maybe the ISO dosent support a native xen cdrom driver (if there is one) ?
>> J-F
>> Â Â-------- Original Message --------
>> Â ÂSubject: Re: [Xen-users] Unable to boot installation ISO
>> Â ÂFrom: "John F. Acree" <john@xxxxxxxxxxxx <mailto:john@xxxxxxxxxxxx>>
>> Â ÂDate: Wed, April 04, 2012 11:40 am
>> Â ÂTo: xen-users@xxxxxxxxxxxxx <mailto:xen-users@xxxxxxxxxxxxx>
>> Â ÂHi,
>> Â ÂI have had a similar problem, and as yet have not had a chance to take
>> Â Âthe screenshot as was requested earlier(maybe this weekend I can get
>> Â Âto it.)
>> Â ÂMy solution, until it can be figured out what needs to be changed so
>> Â Âthe
>> Â Âgentoo minimal cd will boot, is that I used an ubuntu cd.
>> Â ÂI am writing up instructions on this approach, but might be several
>> Â Âdays
>> Â Âor weeks before I release it(my first attempt at technical
>> Â Âdocumentation.)
>> Â ÂBasic steps:
>> Â ÂSelect other install media.
>> Â ÂLoad the ubuntu iso or cd.
>> Â ÂFormat the target drive.
>> Â ÂCopy down the gentoo stage3 and portage archives to the target drive.
>> Â ÂExtract packages, per install instructions.
>> Â ÂChroot as normal and continue with the install instructions.
>> Â ÂHope this helps. But I am not using a gentoo dom0, using xcp 1.5, so
>> Â Âthere are differences.
>> Â ÂJohn
>> Â Â> ÂHi,
>> Â Â> ÂI build Xen 4.1.1 on a Gentoo base dom0. Everything is working
>> Â Âgreat. I
>> Â Â> Âtried one of Joseph Glanville's PV-HVM image (debian6) and its
>> working
>> Â Â> Âas it should.
>> Â Â> ÂNow l'im trying to build a Gentoo based domU with then same specs as
>> Â Â> ÂJoseph's PV-HVM.
>> Â Â> ÂI used a copy of the .cfg and adapted to my needs to make the
>> Â Âgentoo work.
>> Â Â> Âwhen booting the minimal install image using the iso, it starts
>> Â Âloading
>> Â Â> Âthe CD and then when trying to mount the cd-rom it dosent see it .
>> Â Â> Âhere is a copy of the .cfg i used:
>> Â Â> Âkernel = 'hvmloader'
>> Â Â> Âbuilder = 'hvm'
>> Â Â> Âmemory = 4096
>> Â Â> Âvcpus = 4
>> Â Â> Âname = "vm-vps3"
>> Â Â> Âvif = [ 'bridge=virbr0' ]
>> Â Â> Âdisk = ['phy:/dev/vgPool1/VM-VPS3,hda,w',
>> Â Â>
>> Â
>> 'file:/mnt/iso-images/gentoo/amd64/install-amd64-minimal-20120223.iso,hdc:cdrom']
>> Â Â> Âacpi = 1
>> Â Â> Âboot = 'd'
>> Â Â> Âsdl = 0
>> Â Â> Âserial = 'pty'
>> Â Â> Âxen_platform_pci = 1
>> Â Â> Âvnc = 1
>> Â Â> Âvncpasswd = 'password'
>> Â Â> Âvnclisten = 'localhost'
>> Â Â> Âvncdisplay = '343'
>> Â Â> ÂI tried with xen_platform_pci set to 0 but the just hangs to boot
>> Â Â> Âprocedure when loading the sata_piix module.
>> Â Â> Âany ideas on this ?
>> Â Â> ÂThanks,
>> Â Â> ÂJ-F

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.