[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] reboot on booting xen-unstable

  • To: xen-users@xxxxxxxxxxxxx
  • From: Rolu <rolu@xxxxxxxx>
  • Date: Sun, 17 Jun 2012 05:29:18 +0200
  • Delivery-date: Sun, 17 Jun 2012 03:30:57 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

On Sat, Jun 9, 2012 at 3:15 AM, Rolu <rolu@xxxxxxxx> wrote:
> On Thu, Jun 7, 2012 at 3:15 PM, Rolu <rolu@xxxxxxxx> wrote:
>> I've compiled Xen unstable from source and tried using it. When
>> booting I do see Xen starting, but at the point where I normally start
>> getting the dom0 kernel messages I just get a black screen for a few
>> seconds, and then the machine reboots. It leaves no messages or log
>> files, of course.
>> revision I compiled: 25459
>> OS: ubuntu 12.04
>> dom0 kernel 3.2.0-24 (also tried -23), from the repositories. This
>> kernel works with Xen 4.1 from the repositories.
> I just got it to boot with a newer kernel.
> Ubuntu provides recent builds of mainline kernels (details
> https://wiki.ubuntu.com/Kernel/MainlineBuilds?action=show&redirect=KernelMainlineBuilds).
> I downloaded and installed the newest kernel for Ubuntu 12.04
> (precise) from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/
> root@panda:~# uname -a
> Linux panda 3.4.0-030400-generic #201205210521 SMP Mon May 21 09:22:02
> UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
> Still, it could take a long time for that to end up in the default
> Ubuntu kernel, and it might actually be one of Ubuntu's patches that
> broke it. I would much prefer to run with a stock Ubuntu kernel too,
> so this isn't quite solved yet.

I brought this up on the xen-devel list. See

The advice was to add xsave=0 to the Xen kernel line in grub. This
worked and I got the default 3.2 kernel to boot.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.