[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Failed to setup GSI - dom0 Linux Kernel Boot Issues

Having some huge issues with Xen on one of my boxes.

I'm using the package from Arch Linux repository, though I have tried Vanilla source with identical results. This package works on two of my other computers (all it does patch-wise is change the Xen init.d scripts to Arch Linux compatible ones, and add support for xz-compressed dom0 kernels).

My syslinux.cfg menu line is as follows:

  MENU LABEL Xen 4.1.3
  KERNEL mboot.c32
  APPEND ../xen-4.1.3.gz dom0_mem=6000000 --- ../vmlinuz-linux root=/dev/sdb3 ro --- ../initramfs-linux.img

I have rebuilt mkinitcpio with module 'xen-blkfront' in autoload.

When rebooting, the Xen kernel appears to load fine (though I can't confirm, it's not logging anything and it flashes by in a second). It then passes to the Linux kernel and I get:

'Failed to setup GSI :10, err_code:-22' repeated multiple times, '10' can also be '4' and '11'.

Waiting 10 seconds for device /dev/sdb3...
ata7.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata7.00: failed command: READ DMA
ata7.00: cmd c8/00:08:00:00:00/00:00:00:00:00/e0 tag 0 dma 4096 in
res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata7.00: status: {DRDY}

After this I get dropped to rootfs /# prompt, but the keyboard (USB) stops accepting input. The above repeats multiple times, sometimes with 'READ DMA' and sometimes with 'READ MULTIPLE' in its place.

Periodically there are messages like:
INFO: task khubd:85 blocked for more than 120 seconds (khubd can be udevd also)
"echo 0> /proc/sys/kernel/hung_task_timeout_secs" disables this message

Things I've tried:
1. Switching from UUID to /dev/sdb3 in fstab and in /boot/syslinux/syslinux.conf
2. Rebuilding initramfs

Phenom II x6 1100T
16GB DDR3 1600MHz Memory
3x Nvidia GeForce GTX570
2x 500GB HDDs (no RAID, no lvm, just ext2 boot and ext4 root/home partitions)

Booting this same Linux kernel + initramfs without Xen kernel works perfectly (with the obvious sole exception of failing to start the xend service).
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.