[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen-pciback always gives error: Unknown parameter `1)'

On 10/09/12 22:34, Mark van Dijk wrote:
> Quoting Tilo Peter's message from 10 sep 2012:
>> Hi,
>> I tried running debian wheezy amd64 with the debian stock kernel 3.2
>> and xen 4.2 rc3. Compiling ran through without any errors and xen
>> boots up without problems.
>> But xen-pciback always produces the same error message:
>> # lsmod | grep pci
>> pci_stub               12429  0
>> # modprobe xen-pciback
>> ERROR: could not insert 'xen_pciback': Unknown symbol in module, or
>> unknown parameter (see dmesg)
>> # dmesg | tail -n 1
>> [ 3687.470124] xen_pciback: Unknown parameter `1)'
>> This message always appears when I try to load xen-pciback, whenever I
>> give a "hide=(0000:01.00.0)" parameter or not, or in general whatever
>> I do.
>> Since I couldn't find any help on this topic so far, I hope for some
>> idea for a solution here!
> If you load the module on the kernel command line, try to put the whole
> string inside quotes. For example, in my extlinux.conf I have:
> "xen-pciback.hide=(01:00.0)" and I can imagine that you could also try
> this with grub.

I tried this, but it didn't work, just didn't give any effect I could
see. I only checked with "xm pci-list-assignable-devices", or is there
any other way?

> I noticed you have 0000:01.00.0. I see two periods. Are you sure that
> this is right? Usually it should be similar to 01:00.0, 02:00.0,
> 06:04.0 et cetera. Be sure to double check that.

Just a typo, because in the shell it doesnt matter if try "modprobe
xen-pciback", "modprobe xen-pciback 'hide=(01.00.0)'" or "modprobe
xen-pciback foobar" the error message will always be the same.

> If you would rather not have the xen-pciback line in grub but instead
> have the module be loaded during boot or via a manual modprobe, then be
> sure to have something in /etc/modules.conf or /etc/module.d/custom.conf
> (or another name of your own preference) like the following:
> options xen-pciback hide=(01:00.0)(02:00.0)(06:04.0)

OK, this actually worked. Thanks!

> After that, run update-initramfs. Usually I just do either
> "update-initramfs -k all -c" or instead of -c (create new initramfs)
> I use -u (update existing initramfs).
> If that does not work, try to put the full string of the last element
> in quotes and retry again.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.