[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xen 4.2.0, xl dmesg permission denied


Yesterday I've upgraded my box from Xen 4.1.2 to Xen 4.2.0, running a Gentoo 
64bit Dom0. Thus I built all the Xen tools and hypervisor using the Gentoo 
package manager (configured with hvm, pygrub, qemu, screen, and without flask, 
xsm, pae, xend, no custom cflags). With Xen 4.2.0 I can no longer view the 
hypervisor dmesg:

dom0# xl dmesg
libxl: error: libxl.c:4327:libxl_xen_console_read_line: reading console ring 
buffer: Permission denied

VMs wouldn't start:
dom0# xl create config.xen
Parsing config from config.xen
failed to free memory for the domain

I wanted to see the hypervisor messages in order to look into my memory problem 
and the dom0_mem:2G,max:2G boot option did not seem to have any effect:

dom0# head -n 2 /proc/meminfo 
MemTotal:        1697820 kB
MemFree:         1590232 kB

>From /boot/grub2/grub.cfg:
menuentry 'Xen/Gentoo 3.6.2' --class gnu-linux --class gnu --class os {
        insmod raid
        insmod mdraid1x
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='(mduuid/9df8572c68ce035ed264acd1adb42869)'
        search --no-floppy --fs-uuid --set=root 
        echo    'Xen wird geladen'
        multiboot /xen/xen.gz dom0_mem=2G,max:2G iommu=require,verbose
        echo    'Dom0 wird geladen'
        module /xen/image-3.6.2-gentooamd placeholder dom0_mem=2G,max:2G 
        echo    'Done.'

The Dom0 kernel versions I tried are 3.2.11, 3.4.9, and 3.6.2, all with Gentoo 
patchset. I spent a day searching for my permission issue on the net, looking 
into the source code of libxl, reading the kernel config howto for xen, and 
trying to figure out which permissions might be missing. I didn't find anything 
about permissions. When reverting back to Xen 4.1.2 I had an intermediate state 
of still running under hypervisor 4.2, but having xen tools 4.1. In that state 
the "xl dmesg" succeeded. I conclude that there is no permissions issue in the 
hypervisor at all, but I'm out of ideas. Seems there is something wrong in the 
user land tools, but I couldn't figure it out.

In my desperation I tried the latest version from hg which identifies itself as 
4.3-unstable. It failed, too.

Modules I loaded (via modprobe -v):
insmod /lib/modules/3.6.2-gentooamd/kernel/drivers/xen/xen-gntdev.ko
insmod /lib/modules/3.6.2-gentooamd/kernel/drivers/xen/xen-gntalloc.ko

What may be the cause of the "permission denied" message? Where shall I look? 
Any pointers? I hope I've included enough information for you to help me. Let 
me know if there is anything missing.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.