[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Audio PCI passthrough issues in a Linux domU

Hi OJ,

I bought an Intel 3770S and an ASRock H77M that provides a working VT-D setup. I run a minimal Gentoo dom0 with efibootmgr, grub2 and xen-4.2.1-r2 (all ~amd) using the onboard Intel HD4000 and a PS/2 keyboard. I have no X installed and are just now setting up Alsa to test the onboard audio on the dom0. OpenSUSE 12.3 runs fine on the bare metal with onboard Intel VGA.

My recently bought a HIS Radeon HD7750 iCooler that works using secondary VGA passthrough with decent OpenGL 4 support on OpenSUSE 12.3 HVM. Note that I have to reboot dom0 before restarting this domU. I use the fglrx driver as there are no open source drivers for the HD7xxx's with OpenGL 3.2 yet. USB2 passthrough works fine. I trying to passthrough the onboard Intel HD Audio as well but am getting very choppy sound in the domU.

I successfully run Mythbuntu 12.04.2 (amd64) as a HVM domU with PV drivers, but I have yet to try my Hauppauge PVR-150 PCI tv-card. If that does not work via passthrough, I'll probably buy a USB2 tv-stick instead. I could also boot Ubuntu 12.04.2 and 13.04 live CD but did not try to install them.

For both domU's I have to specify the boot disk as hda, because Grub won't boot if I specify it as xvda. I provide the root, home and swap virtual disks via LVM2. Both use PV network drivers and DHCP via my router. The primary VGA is 'stdvga' because that worked a little better than Cirrus emulation. I currently use a VNC program from another PC to interact with both domU's. All domU's use their distribution's default (desktop) kernels and pci_msitranslate, pci_power_mgmt, xen_platform_pci are enabled.

Does this help you, or is there anything more specific that you would like to know?

kind regards, Arjen

On 12-05-13 18:05, Ole Johan Væringstad wrote:
Arjen, Could you tell me a little more about your setup, I'm looking to
set up something similar myself

Do you have X in the dom0? I'm having a hard time getting X to work with
the fglrx drivers in a gentoo dom0
Are you running openSuse, Ubuntu as PV or (PV)HVM guests?
Are you using the fglrx or radeon drivers?

- OJ


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.