[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen IOMMU disabled due to IVRS table... Blah blah blah

Also, I'm pretty much n00b when it comes to IVRS so I'm not entirely
sure what I'm talking about. Meanwhile I've got my Asus rep trying to
fix the issue.  Does anyone have a technical explanation of what
specifically, Asus has to do to fix this issue?

On Tue, May 28, 2013 at 10:40 AM, feral <blistovmhz@xxxxxxxxx> wrote:
> I agree entirely about who should be taking responsibility, but we all
> know of course, that Asus will never fix this.  There are probably
> less than 5000 people in the world affected by this, and if we assume
> most of them will still buy Asus's next board that has working IVRS
> tables, Asus doesn't care.
> I'm more interested in knowing why the
> "iommu=no-amd-iommu-perdev-intremap" option doesn't cover my issue
> though.  It seems odd to me that this option was implemented precisely
> to work around the regression issue, but somehow it didn't catch them
> all.  Goddamn I can't wait for the Xen Documentation to take form :)
> On Tue, May 28, 2013 at 10:35 AM, Jan Hejl <jh@xxxxxxxxxx> wrote:
>> Missing? May be some irony and sarcasm about that "solved". Sure this could 
>> be done better in Xen implementation, but primarly ASUS should be the first 
>> to take a care. These boards are not cheapest so i suppose that they should 
>> work properly. May be i'm wrong.
>> 28. 5. 2013 v 18:56, feral <blistovmhz@xxxxxxxxx>:
>>> On Tue, May 28, 2013 at 4:24 AM, Jan Hejl <jh@xxxxxxxxxx> wrote:
>>>> Hi guys,
>>>> i'm also experiencing this problem with M5A97 EVO R2.0. It has been 
>>>> "solved"
>>>> in Xen 4.2.2 (discused here
>>>> http://lists.xen.org/archives/html/xen-announce/2013-02/msg00006.html). But
>>>> i agree on that that it should be repaired on ASUS side.
>>>> And I'm also facing with prolem about Adaptec 3805 Raid card with enabled
>>>> IOMMU on this motherbord. Without IOMMU storage adapter works perfectly, 
>>>> but
>>>> with enabled IOMMU in BIOS i see the device under linux as block device but
>>>> it's unusable - no data can read or written. Does anyone know what to do
>>>> here, please? Could it be related with bad IOMMU implementation?
>>>> Thanks in advance
>>>> Jan
>>> What am I missing :p ?  What does "solved" in Xen 4.2.2 mean?  The
>>> linked message discusses the original issue of the broken IVRS tables
>>> and the "fix" is to implement checks to disable IOMMU on buggy bios's
>>> after version 4.1.3.  In this case, the "fix" is the problem, unless I
>>> missed something?
> --
> _____
> Fact:
> 1. Ninjas are mammals.
> 2. Ninjas fight ALL the time.
> 3. The purpose of the ninja is to flip out and kill people.

1. Ninjas are mammals.
2. Ninjas fight ALL the time.
3. The purpose of the ninja is to flip out and kill people.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.