[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Trying to create new domain on 4.3 but domU is starting crashed (-sc-)

On Wed, 2013-07-24 at 20:07 +0100, Ian Murray wrote:
> ----- Original Message -----
> > From: Ian Campbell <ian.campbell@xxxxxxxxxx>
> > To: Ian Murray <murrayie@xxxxxxxxxxx>
> > Cc: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
> > Sent: Wednesday, 24 July 2013, 19:36
> > Subject: Re: [Xen-users] Trying to create new domain on 4.3 but domU is 
> > starting crashed (-sc-)
> > 
> > On Wed, 2013-07-24 at 19:22 +0100, Ian Murray wrote:
> >>  Any suggestions would be greatly received. 
> > 
> > Do you get anything out of the guest console? I think if you set
> >     on_crash = "preserve"
> > you can still use "xl console" after the crash or else you can 
> > configure
> > xenconsoled to log as per:
> > http://wiki.xen.org/wiki/Reporting_Bugs_against_Xen#Guest_console_logs
> Thanks for the reply, Ian.
> I tried both of these and got nothing. xl console <nn> just hangs
> until the  ctrl-] out of it and I get no file produced with the
> xenconsoled log (didn't get anything for a working domain, either, so
> I need to re-check I did that right).

Not getting anything from a working domain sounds wrong, there should
definitely be something. You'll need to either "service xencommons
restart" after editing the sysconfig file or a reboot, in any case it
should be apparent in the "ps" output for the xenconsoled command that
the argument has taken affect (it should have --mumble=guest where
mumble is "trace" or "log" or something like that).

Once you are sure of that then you ought to get *something* out of the
crashing guest console -- if not then you might try adding
"earlyprintk=xen" to the guest kernel command line.

> I can't help feeling there is a longstanding problem with 12.04 Ubuntu
> Xen install files. I tried 64 bit and 32 bits version, same behaviour.

If you think it might be an Ubuntu bug then trawling Launchpad might be
worthwhile. Nothing springs to my mind but that doesn't really mean

>  I re-read the other thread and the other guy had exactly the same
> problem but resolved it by using some Ubuntu Xen creation tool. He was
> using Xen 4.2.1

Depending on what "some Ubuntu Xen creation tool" is it may well be
using some different kernel or something.

> http://lists.xen.org/archives/html/xen-users/2013-02/msg00236.html
> Dom0's kernerl is not up-to-date, so I will try to update that before
> I go any further.

That can't hurt, although I wouldn't hold you breath.

Do you get anything on the Xen console (e.g. "xl dmesg")? You might find
adding guest_loglvl=all to your h/v command line gets you more here too.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.