[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Trying to create new domain on 4.3 but domU is starting crashed (-sc-)

  • To: Ian Campbell <ian.campbell@xxxxxxxxxx>
  • From: Ian Murray <murrayie@xxxxxxxxxxx>
  • Date: Thu, 25 Jul 2013 10:41:17 +0100 (BST)
  • Cc: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • Delivery-date: Thu, 25 Jul 2013 09:42:25 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.co.uk; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=R4Qfj7sm1NFRQ3erlXfsKKNAwrjC6KbWGj//mHRWbWGvALrzXud8W0LLoC6mYsbAjfCCnXAld+hK1VcdmO0E8wK+1b+BMRwX4n4wZEfVoguWpWx3IPxGHOX+lxNbWNyvJeSEOU+DwcewV3To77iwqY/OEETusEu6D7EV7gEXPSw=;
  • List-id: Xen user discussion <xen-users.lists.xen.org>

----- Original Message -----
> From: Ian Campbell <ian.campbell@xxxxxxxxxx>
> To: Ian Murray <murrayie@xxxxxxxxxxx>
> Cc: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
> Sent: Thursday, 25 July 2013, 4:37
> Subject: Re: [Xen-users] Trying to create new domain on 4.3 but domU is 
> starting crashed (-sc-)
> On Wed, 2013-07-24 at 20:07 +0100, Ian Murray wrote:
>>  ----- Original Message -----
>>  > From: Ian Campbell <ian.campbell@xxxxxxxxxx>
>>  > To: Ian Murray <murrayie@xxxxxxxxxxx>
>>  > Cc: "xen-users@xxxxxxxxxxxxxxxxxxx" 
> <xen-users@xxxxxxxxxxxxxxxxxxx>
>>  > Sent: Wednesday, 24 July 2013, 19:36
>>  > Subject: Re: [Xen-users] Trying to create new domain on 4.3 but domU 
> is starting crashed (-sc-)
>>  > 
>>  > On Wed, 2013-07-24 at 19:22 +0100, Ian Murray wrote:
>>  >>  Any suggestions would be greatly received. 
>>  > 
>>  > Do you get anything out of the guest console? I think if you set
>>  >     on_crash = "preserve"
>>  > you can still use "xl console" after the crash or else you 
> can 
>>  > configure
>>  > xenconsoled to log as per:
>>  > http://wiki.xen.org/wiki/Reporting_Bugs_against_Xen#Guest_console_logs
>>  Thanks for the reply, Ian.
>>  I tried both of these and got nothing. xl console <nn> just hangs
>>  until the  ctrl-] out of it and I get no file produced with the
>>  xenconsoled log (didn't get anything for a working domain, either, so
>>  I need to re-check I did that right).
> Not getting anything from a working domain sounds wrong, there should
> definitely be something. You'll need to either "service xencommons
> restart" after editing the sysconfig file or a reboot, in any case it
> should be apparent in the "ps" output for the xenconsoled command that
> the argument has taken affect (it should have --mumble=guest where
> mumble is "trace" or "log" or something like that).

root      1526  0.0  0.1  90956  1096 ?        SLl  Jul24   0:00 
/usr/sbin/xenconsoled --pid-file=/var/run/xenconsoled.pid --log=guest

I must admit, I never have it straight in my head about hvc0 vs xvc0, etc. 
earlyprintk=xen doesn't seem to have made any difference.

I am wondering if I did something wrong at compile time (it has been known)

> Once you are sure of that then you ought to get *something* out of the
> crashing guest console -- if not then you might try adding
> "earlyprintk=xen" to the guest kernel command line.
>>  I can't help feeling there is a longstanding problem with 12.04 Ubuntu
>>  Xen install files. I tried 64 bit and 32 bits version, same behaviour.
> If you think it might be an Ubuntu bug then trawling Launchpad might be
> worthwhile. Nothing springs to my mind but that doesn't really mean
> much.
>>   I re-read the other thread and the other guy had exactly the same
>>  problem but resolved it by using some Ubuntu Xen creation tool. He was
>>  using Xen 4.2.1
> Depending on what "some Ubuntu Xen creation tool" is it may well be
> using some different kernel or something.

He succesfully created it using

xen-create-image --hostname=ubuntu \
  --memory=512mb \
  --vcpus=2 \
  --lvm=center \
  --dhcp \
  --pygrub \

I've never used this tool and I prefer to do things distribution agnostically 
as I have Xen on Ubuntu and Scientific Linux 6.4

>>  http://lists.xen.org/archives/html/xen-users/2013-02/msg00236.html
>>  Dom0's kernerl is not up-to-date, so I will try to update that before
>>  I go any further.
> That can't hurt, although I wouldn't hold you breath.

It didn't hurt but it didn't help. Was always a long shot.

> Do you get anything on the Xen console (e.g. "xl dmesg")? You might 
> find
> adding guest_loglvl=all to your h/v command line gets you more here too.

Nothing very interesting even when I do that...

root@xen6:/var/log/xen# xl dmesg
 __  __            _  _    _____  ___  
 \ \/ /___ _ __   | || |  |___ / / _ \ 
  \  // _ \ '_ \  | || |_   |_ \| | | |
  /  \  __/ | | | |__   _| ___) | |_| |
 /_/\_\___|_| |_|    |_|(_)____(_)___/ 
(XEN) Xen version 4.3.0 (root@) (gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3) 
debug=n Tue Jul  9 16:03:18 BST 2013
(XEN) Latest ChangeSet: Tue Jul 9 11:46:56 2013 +0100 git:f8cc9c2
(XEN) Bootloader: GRUB 1.99-21ubuntu3.9
(XEN) Command line: placeholder dom0_mem=1024M,max:1024M loglvl=all 
(XEN) Video information:
(XEN)  VGA is text mode 80x25, font 8x16
(XEN)  VBE/DDC methods: none; EDID transfer time: 0 seconds
(XEN)  EDID info not retrieved because no DDC retrieval method detected
(XEN) Disc information:
(XEN)  Found 1 MBR signatures
(XEN)  Found 1 EDD information structures
(XEN) Xen-e820 RAM map:
(XEN)  0000000000000000 - 000000000009d800 (usable)
(XEN)  000000000009d800 - 00000000000a0000 (reserved)
(XEN)  00000000000e0000 - 0000000000100000 (reserved)
(XEN)  0000000000100000 - 0000000020000000 (usable)
(XEN)  0000000020000000 - 0000000020200000 (reserved)
(XEN)  0000000020200000 - 0000000040000000 (usable)
(XEN)  0000000040000000 - 0000000040200000 (reserved)
(XEN)  0000000040200000 - 00000000d8c15000 (usable)
(XEN)  00000000d8c15000 - 00000000d9314000 (reserved)
(XEN)  00000000d9314000 - 00000000d9429000 (ACPI NVS)
(XEN)  00000000d9429000 - 00000000da5dc000 (reserved)
(XEN)  00000000da5dc000 - 00000000da5dd000 (usable)
(XEN)  00000000da5dd000 - 00000000da620000 (ACPI NVS)
(XEN)  00000000da620000 - 00000000daa33000 (usable)
(XEN)  00000000daa33000 - 00000000daff4000 (reserved)
(XEN)  00000000daff4000 - 00000000db000000 (usable)
(XEN)  00000000db800000 - 00000000dfa00000 (reserved)
(XEN)  00000000f8000000 - 00000000fc000000 (reserved)
(XEN)  00000000fec00000 - 00000000fec01000 (reserved)
(XEN)  00000000fed00000 - 00000000fed04000 (reserved)
(XEN)  00000000fed1c000 - 00000000fed20000 (reserved)
(XEN)  00000000fee00000 - 00000000fee01000 (reserved)
(XEN)  00000000ff000000 - 0000000100000000 (reserved)
(XEN)  0000000100000000 - 000000041e600000 (usable)
(XEN) ACPI: RSDP 000F0490, 0024 (r2 ALASKA)
(XEN) ACPI: XSDT D941A078, 006C (r1 ALASKA    A M I  1072009 AMI     10013)
(XEN) ACPI: FACP D9423D80, 010C (r5 ALASKA    A M I  1072009 AMI     10013)
(XEN) ACPI: DSDT D941A178, 9C03 (r2 ALASKA    A M I       21 INTL 20051117)
(XEN) ACPI: FACS D9427080, 0040
(XEN) ACPI: APIC D9423E90, 0062 (r3 ALASKA    A M I  1072009 AMI     10013)
(XEN) ACPI: FPDT D9423EF8, 0044 (r1 ALASKA    A M I  1072009 AMI     10013)
(XEN) ACPI: MCFG D9423F40, 003C (r1 ALASKA    A M I  1072009 MSFT       97)
(XEN) ACPI: HPET D9423F80, 0038 (r1 ALASKA    A M I  1072009 AMI.        5)
(XEN) ACPI: SSDT D9423FB8, 036D (r1 SataRe SataTabl     1000 INTL 20091112)
(XEN) ACPI: SSDT D9424328, 0926 (r1  PmRef  Cpu0Ist     3000 INTL 20051117)
(XEN) ACPI: SSDT D9424C50, 0A92 (r1  PmRef    CpuPm     3000 INTL 20051117)
(XEN) ACPI: ASF! D94256E8, 00A5 (r32 INTEL       HCG        1 TFSM    F4240)
(XEN) System RAM: 16241MB (16631624kB)
(XEN) No NUMA configuration found
(XEN) Faking a node at 0000000000000000-000000041e600000
(XEN) Domain heap initialised
(XEN) found SMP MP-table at 000fd750
(XEN) DMI 2.7 present.
(XEN) Using APIC driver default
(XEN) ACPI: PM-Timer IO Port: 0x408
(XEN) ACPI: v5 SLEEP INFO: control[0:0], status[0:0]
(XEN) ACPI: SLEEP INFO: pm1x_cnt[404,0], pm1x_evt[400,0]
(XEN) ACPI: 32/64X FACS address mismatch in FADT - d9427080/0000000000000000, 
using 32
(XEN) ACPI:             wakeup_vec[d942708c], vec_size[20]
(XEN) ACPI: Local APIC address 0xfee00000
(XEN) ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
(XEN) Processor #0 6:10 APIC version 21
(XEN) ACPI: LAPIC (acpi_id[0x02] lapic_id[0x02] enabled)
(XEN) Processor #2 6:10 APIC version 21
(XEN) ACPI: LAPIC_NMI (acpi_id[0xff] high edge lint[0x1])
(XEN) ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
(XEN) IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-23
(XEN) ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
(XEN) ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
(XEN) ACPI: IRQ0 used by override.
(XEN) ACPI: IRQ2 used by override.
(XEN) ACPI: IRQ9 used by override.
(XEN) Enabling APIC mode:  Flat.  Using 1 I/O APICs
(XEN) ACPI: HPET id: 0x8086a701 base: 0xfed00000
(XEN) ERST table was not found
(XEN) Using ACPI (MADT) for SMP configuration information
(XEN) SMP: Allowing 2 CPUs (0 hotplug CPUs)
(XEN) IRQ limits: 24 GSI, 376 MSI/MSI-X
(XEN) Using scheduler: SMP Credit Scheduler (credit)
(XEN) Detected 2893.511 MHz processor.
(XEN) Initing memory sharing.
(XEN) xstate_init: using cntxt_size: 0x240 and states: 0x3
(XEN) mce_intel.c:717: MCA Capability: BCAST 1 SER 0 CMCI 1 firstbank 0 
extended MCE MSR 0
(XEN) Intel machine check reporting enabled
(XEN) PCI: MCFG configuration 0: base f8000000 segment 0000 buses 00 - 3f
(XEN) PCI: MCFG area at f8000000 reserved in E820
(XEN) PCI: Using MCFG for segment 0000 bus 00-3f
(XEN) I/O virtualisation disabled
(XEN) Enabled directed EOI with ioapic_ack_old on!
(XEN)  -> Using old ACK method
(XEN) ..TIMER: vector=0xF0 apic1=0 pin1=2 apic2=-1 pin2=-1
(XEN) TSC deadline timer enabled
(XEN) Platform timer is 14.318MHz HPET
(XEN) Allocated console ring of 16 KiB.
(XEN) mwait-idle: MWAIT substates: 0x1120
(XEN) mwait-idle: v0.4 model 0x2a
(XEN) mwait-idle: lapic_timer_reliable_states 0xffffffff
(XEN) VMX: Supported advanced features:
(XEN)  - APIC MMIO access virtualisation
(XEN)  - APIC TPR shadow
(XEN)  - Extended Page Tables (EPT)
(XEN)  - Virtual-Processor Identifiers (VPID)
(XEN)  - Virtual NMI
(XEN)  - MSR direct-access bitmap
(XEN)  - Unrestricted Guest
(XEN) HVM: ASIDs enabled.
(XEN) HVM: VMX enabled
(XEN) HVM: Hardware Assisted Paging (HAP) detected
(XEN) HVM: HAP page sizes: 4kB, 2MB
(XEN) Brought up 2 CPUs
(XEN) ACPI sleep modes: S3
(XEN) mcheck_poll: Machine check polling timer started.
(XEN)  Xen  kernel: 64-bit, lsb, compat32
(XEN)  Dom0 kernel: 64-bit, PAE, lsb, paddr 0x1000000 -> 0x2060000
(XEN)  Dom0 alloc.:   0000000408000000->000000040c000000 (235679 pages to be 
(XEN)  Init. ramdisk: 000000041be9f000->000000041e5ff400
(XEN)  Loaded kernel: ffffffff81000000->ffffffff82060000
(XEN)  Init. ramdisk: ffffffff82060000->ffffffff847c0400
(XEN)  Phys-Mach map: ffffffff847c1000->ffffffff849c1000
(XEN)  Start info:    ffffffff849c1000->ffffffff849c14b4
(XEN)  Page tables:   ffffffff849c2000->ffffffff849eb000
(XEN)  Boot stack:    ffffffff849eb000->ffffffff849ec000
(XEN)  TOTAL:         ffffffff80000000->ffffffff84c00000
(XEN)  ENTRY ADDRESS: ffffffff81cfc200
(XEN) Dom0 has maximum 2 VCPUs
(XEN) Scrubbing Free RAM: 
(XEN) Initial low memory virq threshold set at 0x4000 pages.
(XEN) Std. Loglevel: All
(XEN) Guest Loglevel: All
(XEN) Xen is relinquishing VGA console.
(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch input to 
(XEN) Freed 264kB init memory.
(XEN) PCI add device 0000:00:00.0
(XEN) PCI add device 0000:00:02.0
(XEN) PCI add device 0000:00:14.0
(XEN) PCI add device 0000:00:16.0
(XEN) PCI add device 0000:00:1a.0
(XEN) PCI add device 0000:00:1b.0
(XEN) PCI add device 0000:00:1c.0
(XEN) PCI add device 0000:00:1c.1
(XEN) PCI add device 0000:00:1d.0
(XEN) PCI add device 0000:00:1e.0
(XEN) PCI add device 0000:00:1f.0
(XEN) PCI add device 0000:00:1f.2
(XEN) PCI add device 0000:00:1f.3
(XEN) PCI add device 0000:02:00.0

> Ian.

I repeated the exercise on my SL machine which worked fine. This is running Xen 
4.2.2 (compiled from tar rather than git rep), although I wouldn't read too 
much into this because the other person was having similar issues using 4.2.1. 
Having said that, his issues went away when he reverted back to 4.1.x

I am going to revert this machine back to 4.2.2 to see what happens.

> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxx
> http://lists.xen.org/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.