[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VGA Passthrough of AMD FirePro W7000 to Windows 8: Not enough resources

> On 2 Oct 2013, at 14:06, Gordan Bobic <gordan@xxxxxxxxxx> wrote:
>> On 10/02/2013 01:58 PM, Toby Miller wrote:
>> >> gordan@xxxxxxxxxx wrote:
>>>  On Sun, 29 Sep 2013 15:01:01 +0100, Toby
>>> Miller<tobycmiller@xxxxxxxxx>   wrote:
>>>> >I'm using Xen 4.3, installed from source on Ubuntu 13.04. I've
>>>> >successfully installed a Windows 8 guest, and had Xen pass it an AMD
>>>> >FirePro W7000 GPU (technically 2 PCI devices - the second is for the
>>>> >sound), as well as the virtualised graphics adapter. Windows finds
>>>> >the
>>>> >card fine, and I've installed AMD's drivers. Device Manager says that
>>>> >the card cannot find enough resources (code 12). I've checked the IO,
>>>> >IRQ, and Memory details in DM, and there don't seem to be any
>>>> >clashes.
>>>> >
>>>> >I did try disabling the virtualised card from Windows, but it seemed
>>>> >to keep using it anyway, even after a restart. It didn't make any
>>>> >difference to the FirePro in any case.
>>>> >
>>>> >I'd be grateful for some help.
>>>  I haven't tried Windows 8, but on XP64 disabling the Cirrus card in
>>>  device manager fixed the problem for me with Nvidia card passthrough.
>>>  You could try setting gfx_passthru=1, which should disable the
>>>  Cirrus emulation alltogether. That may make Windows domU completely
>>>  fail to boot, though.
>>>  Did you do a clean Win8 install and reboot the host fully? Is the
>>>  FirePro the primary GPU on the host? Or is it completely untouched
>>>  in dom0 (no dom0 or BIOS output on it)?
>>>  Gordan
>> Thanks for your reply. It turns out the problem was that I'd forgotten
>> to put device_model_version="qemu-xen-traditional", so I was using a
>> qemu that didn't support gfx_passthrough. The FirePro is not used in
>> dom0 at all. I'm using pciback to hide it.
>> I now have another problem though. The Ubuntu host crashes a lot when
>> the Windows 8 guest is running. Mostly it happens when I try to shut
>> down Windows - I think it might be a result of the FirePro card being
>> released -, but sometimes it happens randomly too. The screen completely
>> freezes, and no ssh or anything. I should mention that I'm not passing
>> through the audio pci device for the FirePro, although it is bound to
>> pciback so the host can't be using it either. If I try to pass that
>> through it never actually boots. I've had a lot of blue screens, and a
>> lot of host crashes. I'm passing through a USB device too (i.e. the PCI
>> USB device), and that works fine.
>> Googling doesn't seem to come up with much for host crashes. What can I
>> do to diagnose the problem? There's nothing in the syslog.
> Can you try it with domU limited to 1GB of RAM? Also, can you add your 
> physical e820 memory map as reported in dmesg?
> It is plausible you might be running into the same issue I had with domU 
> memory overwriting the physical IOMEM without getting remapped by the IOMMU.
> Does your motherboard feature NF200 PCIe bridges?
> Gordan

Your overwriting memory suggestion sounds likely. I've tried with 1GiB
but the host still crashes a lot. The first time I ran it it booted,
and then shutdown fine, but starting it again crashed the host. The
second and third tries resulted in a host crash before Windows had
booted even once. Sometimes as the host crashes the mouse movement
slows down, before stopping altogether. Would this make sense if the
host's memory were being overwritten?

Is this the memory map you wanted?:

[root@yeti /etc/xen]% dmesg | grep e820
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] e820: update [mem 0x00000000-0x0000ffff] usable ==> reserved
[    0.000000] e820: remove [mem 0x000a0000-0x000fffff] usable
[    0.000000] e820: last_pfn = 0x880000 max_arch_pfn = 0x400000000
[    0.000000] e820: last_pfn = 0x7d800 max_arch_pfn = 0x400000000
[    0.000000] e820: [mem 0x90000000-0xfed1bfff] available for PCI devices
[    8.827099] e820: reserve RAM buffer [mem 0x0009e000-0x0009ffff]
[    8.827101] e820: reserve RAM buffer [mem 0x7cdad000-0x7fffffff]
[    8.827103] e820: reserve RAM buffer [mem 0x7d334000-0x7fffffff]
[    8.827105] e820: reserve RAM buffer [mem 0x7d800000-0x7fffffff]

The motherboard is an EVGA SR-X, and I'm not sure how to tell whether
it has NF200 PCIe bridges.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.