[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Bridging works fine under KVM but not Xen


I've just recently gotten to re-visit an issue I've been having
getting Xen bridging to work on a host I'm trying to build. I
originally posted my issue back in late November under the topic "Dom0
seeing traffic on br0 but it's not routing".

The issue is that the hvm DomU does see traffic when I do a tcpdump on
the primary interface that is running of the bridge, but it can't
route past the host. I can ping the host, but not anything past it.

Thought it could be a MAC filtering issue on the switch, so I took the
MAC from the DomU and spoofed it on the Dom0 without any issues,
traffic routed normally.

Now this is a new build so for testing purposes I went ahead and wiped
it, did a KVM install instead of a Xen, setup the bridged network the
exact way that I did for the Xen build, and bridging worked right out
of the box (hvm as well).

This makes me conclude that there is an issue w/the Xen configuration
itself? I'm running CentOS 6.5 x86_64 for both KVM and Xen. I thought
maybe it was the Xen implementation for CentOS so I tried SuSE and got
the same results.

I've seen things you people wouldn't believe. Attack ships on fire off
the shoulder of Orion. I watched C-beams glitter in the dark near the
Tannhauser gate. All those moments will be lost in time... like tears
in rain... Time to die.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.