[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Bridging works fine under KVM but not Xen

>> I've just recently gotten to re-visit an issue I've been having
>> getting Xen bridging to work on a host I'm trying to build. I
>> originally posted my issue back in late November under the topic "Dom0
>> seeing traffic on br0 but it's not routing".
> Did you try out all suggestions provided by Alexandre in the original
> email thread?


>> The issue is that the hvm DomU does see traffic when I do a tcpdump on
>> the primary interface that is running of the bridge, but it can't
>> route past the host. I can ping the host, but not anything past it.
>> Thought it could be a MAC filtering issue on the switch, so I took the
>> MAC from the DomU and spoofed it on the Dom0 without any issues,
>> traffic routed normally.
>> Now this is a new build so for testing purposes I went ahead and wiped
>> it, did a KVM install instead of a Xen, setup the bridged network the
>> exact way that I did for the Xen build, and bridging worked right out
>> of the box (hvm as well).
> This is a bit confusing. KVM only supports hardware virtualization.
> Does the KVM guest has the exact same MAC address as Xen HVM guest?

I'm not too familar with KVM so wasn't aware that it was HVM only. The
domain type in the xml config was set to 'hvm' so I assumed other
options could go there. I'm only using it for testing purposes to
verify it's not a switch/network issue.

The MAC was generated w/the same method I used for the Xen guest.
Using the following Python snippet "import virtinst.util ; print
virtinst.util.randomMAC()". This method has worked on other Xen hosts.

>> This makes me conclude that there is an issue w/the Xen configuration
>> itself? I'm running CentOS 6.5 x86_64 for both KVM and Xen. I thought
>> maybe it was the Xen implementation for CentOS so I tried SuSE and got
>> the same results.
> I still don't see anything obivous. Do you have anything specific
> configured for Xen? Having a look at content of the Xen package you use
> might provide some clues.

Nope. I'm using whatever the defaults are out of the RPMs for CentOS
6.x. I'm creating my own domain configs, here's an example if that

device_model = "/usr/lib/xen-4.2/bin/qemu-dm"
disk=[ "qcow2:/data/images/centos-6.4-x86_64.qc2,hda,w" ]

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.