[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] BSOD after installing EJB Digital GPLPV Drivers on fresh Windows 2008 R2 Enterprise

  • To: James Harper <james.harper@xxxxxxxxxxxxxxxx>, "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: Jan Hejl <jh@xxxxxxxxxx>
  • Date: Wed, 08 Jan 2014 21:55:30 +0100
  • Delivery-date: Wed, 08 Jan 2014 20:56:14 +0000
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=excello.cz; h=message-id :date:from:mime-version:to:subject:references:in-reply-to :content-type; q=dns; s=default; b=e3LPNxSbJY6XNDw2PemUdy15h5d3j 9NslltVtURMlabH6icmP8D4Nz4Fit7IC9i4kTnO61RN41ANKfFq/Q81co1IZodUW BEm3bIu411jdAV9VSZ7A8EJp05K18NH3kuGY9wWSETVb80JUxokr0KhRhypvbPMX FC3JpQjedOdkE0=
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Dne 8.1.2014 01:06, James Harper napsal(a):
Hi everyone,

i've just installed new (clean and fully updated) Windows 2008 R2
Enterprise domU on Xen 4.3.1-r1 (Gentoo, hardened, kernel 3.11.2) as
PVHVM and tried to install GPLPV to make it work as proper PVHVM domU.
But after installing the newest signed drivers from
http://www.ejbdigital.com.au/GPLPV/ (doesn't matter which version) it
seems fine until reboot. Then it throws BSOD with
DRIVER_IRQL_NOT_LESS_OR_EQUAL (see attached image).

Same problem with older Univention drivers.

When I remove vif device from xen config file, windows domU goes fine,
but it's useless without internet connection.

Any ideas what can be wrong? Disabling IPv6 through regedit didn't help
at all.

vif = [
        'bridge=xenbr1, script=vif-bridge, mac=00:16:3e:58:cc:24,

Can you try omitting the model from the vif declaration? That's the only 
difference I can see between yours and my servers.

The crashing driver is reported as sacdrv.sys, but that's part of the OS as far 
as I can tell. Maybe there is something about the e1000 driver that windows 
doesn't like having it unplugged by GPLPV?


Hi James,

unfortunately ommiting model declaration didn't help. I also tried to install last drivers from uninvention.de (with ommited model declaration) and it throws another exception (see attachment).

Could you please post your config, please?

Maybe i'm missing something, could you please post your install steps? Or check mine?

1. Install clean Windows 2008 R2 machine
2. Install all windows updates
3. Install GPLPV drivers.
4. ... it should work, but it doesn't for me ...

Thank you and have a nice day

Attachment: xennet.sys.png
Description: PNG image

Attachment: smime.p7s
Description: Elektronicky podpis S/MIME

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.