[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] BSOD after installing EJB Digital GPLPV Drivers on fresh Windows 2008 R2 Enterprise

  • To: James Harper <james.harper@xxxxxxxxxxxxxxxx>, "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: Jan Hejl <jh@xxxxxxxxxx>
  • Date: Thu, 09 Jan 2014 11:55:15 +0100
  • Delivery-date: Thu, 09 Jan 2014 10:55:30 +0000
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=excello.cz; h=message-id :date:from:mime-version:to:subject:references:in-reply-to :content-type; q=dns; s=default; b=Lx/OMPnO6Bk6nefWs6Tl3cNw8J2ic mp/OaPbOecUb4TLXfx/kFKbovfdI8WJOAqLgf8d1PbhNZaihx7Dx9lVWcDf8LAHW WDiw8Nfq4DojdOblVyKGvwPQrGoiEoB54qwlc5fTIK3xxHd4+SjGlox5Ry0QDAui QhJP0ZP0kT3IUo=
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Dne 8.1.2014 23:01, James Harper napsal(a):
Dne 8.1.2014 01:06, James Harper napsal(a):
Hi everyone,

i've just installed new (clean and fully updated) Windows 2008 R2
Enterprise domU on Xen 4.3.1-r1 (Gentoo, hardened, kernel 3.11.2) as
PVHVM and tried to install GPLPV to make it work as proper PVHVM
But after installing the newest signed drivers from
http://www.ejbdigital.com.au/GPLPV/ (doesn't matter which version) it
seems fine until reboot. Then it throws BSOD with
DRIVER_IRQL_NOT_LESS_OR_EQUAL (see attached image).

Same problem with older Univention drivers.

When I remove vif device from xen config file, windows domU goes fine,
but it's useless without internet connection.

Any ideas what can be wrong? Disabling IPv6 through regedit didn't help
at all.

vif = [
        'bridge=xenbr1, script=vif-bridge, mac=00:16:3e:58:cc:24,
Can you try omitting the model from the vif declaration? That's the only
difference I can see between yours and my servers.
The crashing driver is reported as sacdrv.sys, but that's part of the OS as far
as I can tell. Maybe there is something about the e1000 driver that windows
doesn't like having it unplugged by GPLPV?

Hi James,

unfortunately ommiting model declaration didn't help. I also tried to
install last drivers from uninvention.de (with ommited model
declaration) and it throws another exception (see attachment).

Could you please post your config, please?

Maybe i'm missing something, could you please post your install steps?
Or check mine?

1. Install clean Windows 2008 R2 machine
2. Install all windows updates
3. Install GPLPV drivers.
4. ... it should work, but it doesn't for me ...

I always install PV drivers before installing updates (takes forever 
otherwise), but other than that that's exactly what I do. Installing the 
updates first won't make a difference.

Next, please make the following changes to your config file, just to test:

Change memory to 2048
Get rid of audio= and soundhw= lines
Change vcpus to 1

If that resolves the problem, please tinker with the above to see if you can 
isolate which caused the problem. If I get a minute I'll try your config on my 
server. I'm not confident that it will make any difference though.

Are you using a non-english version of Windows. I seem to remember someone else 
reporting a problem that I couldn't reproduce, and the only difference was that 
they were using a non-english version of Windows. If you are, do you have an 
English language version you could test with to see if the problem remains?


Changes to domU configuration didn't help.

The only thing that left to be different (in my opinion) was Windows edition. So I installed Windows 2008 R2 Standard x64 edition (all the time it is packed with SP1, English version) and it works! Hell yeah! I also was able to run domU with 8 vcpus and 16GB of memory.

Is there anything that could break things on Enterprise edition? Do you want me to do some other tests/debugs?

Thank you!

Attachment: smime.p7s
Description: Elektronicky podpis S/MIME

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.