[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen on ARM: booting Linux from a physical partition

On Mon, 2014-02-24 at 11:37 -0800, Jonathan Daugherty wrote:
> Hi,
> I want to boot a Linux system from a root filesystem installed on an SD
> card partition using an Arndale board.  To do this, I have a domain
> configuration file,
>   kernel = "/linux-domU"
>   memory = 128
>   name = "guest"
>   vcpus = 1
>   disk = [ 'phy:/dev/mmcblk1p4,xvda,w' ]
>   extra = "... root=/dev/xvda ..."
> I set up the filesystem by writing an ext3 filesystem image to the
> partition mentioned in the config using 'dd'.  When the guest kernel
> boots, I see
>   blkfront: xvda: barrier or flush: disabled; persistent
>     grants: enabled; indirect descriptors: disabled;
>   xvda: unknown partition table
> and then
>   List of all partitions:
>   ca00          991232 xvda  driver: vbd
>   No filesystem could mount root, tried:  ext3 ext4 vfat fuseblk
>   Kernel panic - not syncing: VFS: Unable to mount root fs on
>     unknown-block(202,0)
> I tried the 'file:' scheme for the disk setting in the configuration
> file, but that causes the system to try to start QEMU.
> In general the partition table message I mentioned is not problematic as
> long as the device in question is not treated as a partitioned disk; I'd
> just like to mount /dev/xvda rather than treat it that way, and
> historically I've never had problems doing that.  And for what it's
> worth, if I provide a physical device with a partition table instead of
> blk1p4, the behavior is the same.
> What am I missing?

What kernel versions are you using in dom0/domU? Prior to v3.12 Linux
had a bug in the block device ABI, which was fixed in v3.13. However
this means that Linux <= v3.12 can only interact with other such

The no-partition thing is fine, I do the same and ignore the same


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.