[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Fwd: DomU freeze

On Mon, 2014-02-24 at 13:54 -0700, Shane Johnson wrote:
> On Mon, Feb 24, 2014 at 2:34 AM, Ian Campbell
> <Ian.Campbell@xxxxxxxxxx> wrote:
>         On Thu, 2014-02-20 at 12:03 -0700, Shane Johnson wrote:
>         > I apparently forgot to forward this on to the list - Sorry
>         about that.
>         [...]
>         > Sorry for the vagueness.  I was trying to keep  things short
>         and sweet
>         > but I guess I failed.  I'll do better next time.
>         No worries.
>         > The Guest domains storage was on dedicated logical volumes.
>          These I
>         > would snapshot and image for a backup.   When the Dom0
>         crashed, I lost
>         > the original volumes and restored them from the images to
>         new volumes
>         > that are currently on a external HD for portability for
>         trying to get
>         > this bugger up or worst case resort to trying to recover the
>         files
>         > using some sort of forensic process.  Unfortunately, I lost
>         the
>         > original host OS and all the configuration files.  The
>         guests where
>         > originally created on either this machine that crashed or my
>         desktop
>         > and migrated via sneaker net to the crashed host.
>         >
>         >
>         > Yes the machine I am having a problem with is a HVM guest
>         running
>         > Windows 2000 that's sole purpose was a file server.
>         >
>         >
>         > The 100% CPU usage was for the DomU in xl top.
>         Are you sure you were using xl before? The default in Wheezy
>         was xend/xm
>         and the version of xl in Xen 4.1 (in Wheezy) is a bit tech
>         preview.
> Yes, I read that  xl is the future toolstack, so I switched my hosts
> to it so I wouldn't have to catch up later.

Does this issue go away if you use xend on 4.1? Or xl from 4.3 onwards?

>         From your screenshot it looks like the BIOS trying to read
>         from the
>         CDROM.
> I have tried it with boot = "cd" and "dc" and whether or not  I press
> a key to get  into windows setup, it always acts the same way -
> freezing right when it would seem like it should be accessing the MBR
> of the disk.
>         You have disks named "xvd?" and xen_platform_pci=0, which I
>         think it a
>         bit unusual, I'm not sure what the result would be. Can you
>         try naming
>         your disks "hd?" instead.
> From reading http://xenbits.xen.org/docs/4.2-testing/man/xl.cfg.5.html
> it was my understanding these where needed or at least desirable for
> guests using the GPLPV drivers.  I use the xvd for the disks cause I
> found it easier for the cd-rom stuff. 

xen_platform_pci=0 will disable the PV driver stuff, which is why I say
it is unusual.

Also cdroms are most often not dealt with via PV but always via
emulation (which supports things like unplug notifications).

Please try using the hd names for both, and then for just the cdrom.

>         > xenctx says it can't trace dom0
>         You need to give it a domid as a parameter.
> I get this message no matter what domain I enter into the command.

Did you give it a domid? i.e. a number not a name. You can get the domid
from xl/xm list  or from "xl domid <name>" (I don't think xm domid

>   Please let me know if you would like me to try this again with the
> hd in the disk parameters.

Yes please.

> I rereading some material since my last post, a question has come to
> mind, what effect would not pausing the domain have on the bootability
> of the image file?

What do you mean "not pausing"? Are you starting with "xl create -p" and
then "xl unpause"? Are you doing something in the middle?

It might be worth trying your configuration with a fresh/undamaged
Windows install -- just to rule out some weird disk corruption. Although
you having run fixmbr and friends does seem like it might rule that out,
but I don't know what the Windows mbr and bootloader actually do --
perhaps the corrupted filesystems are enough to send them into a

> Here is some other information.  I have been able to add the LVM's to
> another windows instance but everything just come across as the
> dynamic volumes are corrupted and I can see the files of the Basic
> volume.  The basic partition is just the Windows OS and the dynamic
> volumes are where the data I need is.  I was trying to reboot the
> original OS volume to try and see if it would recognize the dynamic
> volumes, but that is what keeps freezing.  I have tried some
> file/partition recovery software with no luck.  If anyone has any
> ideas on how I can get this data back it would be greatly appreciated.

I'm afraid I don't know what to recommend for Window's data recovery,
perhaps someone else on the list has some advice.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.