[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XENBUS timeout connecting to device (Hard disks not detected)

On Mon, 2015-01-05 at 11:15 -0500, Philippe-A. Lemelin wrote:
> On 15-01-05 10:33 AM, Ian Campbell wrote:
> > George, is blktap expected to work with the xen4centos (6) packages?
> >
> > (not trimming quotes for George's benefit)
> >
> > I wonder if tap vs. tap2 is a xend vs xl thing.
> >
> This is not the first installation of Xen we did but it is the first 
> time we have seen this behavior (see lower in this email, forcing tap2 
> solved the installation issue). We currently have 4 Dom0 running the 
> same hardware/OS but installed at different time in the last 6 months. 
> The installation is a manual process but respects the same written 
> procedure each time so there must have been a change in CentOS packages 
> somewhere at the end of November or the beginning of December. We are 
> still trying to figure what the difference is.

I'd check the list of loaded modules, for xen-blktap.ko vs
xen-blktap2.ko or some such.

> >> I will try to force the driver to tap2 during the installation with
> >> driver_name=tap2,driver_type=aio.
> >>
> We have forced the driver to tap2 and the disks where discovered by the 
> installer this time and everything completed successfully.


> >>
> >>> Do you know which toolstack libvirt is talking to, either xend or libxl.
> >>
> >> Where can I find this information ?
> >
> > Do you have a xend process running?
> >
> Yes and using "xl list" does return the details on my Dom0 and DomU. 
> Does that mean xl is used?

I don't think so, I think libvirt will use xend by preference if it is
running. George also suggested that the version of libvirt you are using
doesn't know how to drive libxl anyway.

I'm far from an expert on this layer though.

> > I seem to have temporarily b0rked my libvirt test box, but perhaps
> > "virsh" has an option to say which backend it would use, or maybe it
> > appears in tne output of "virsh capabilities"?
> >
> I ran "virsh version":
> virsh # version --daemon
> Compiled against library: libvirt 0.10.2
> Using library: libvirt 0.10.2
> Using API: Xen 0.10.2
> Running hypervisor: Xen 4.2.0
> Running against daemon: 0.10.2
> Also, under /var/lib/libvirt, I only have 2 log files, libvirtd.log and 
> under libxl, libxl.log

That does seem to suggest you have the option of using libxl though, so
maybe George is mistaken.

> virsh capabilities does not seem to have this information.
> > Ian.
> >
> Again, thank you for you help with this issue.
> Philippe-A. Lemelin

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.