[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Xen-Users] Issues with root NFS on Dom0

Hi Brandon,

I tried a NFS root solution for my group of dom0 hosts a number of years ago (using xen4.0). Due to a number of lockups and issues I suffered over a period of time my "solution" which has worked very well for me, using a custom initrd I actually copy the rootfs to a ram disk, and then boot from memory. This meant that I no longer had to worry about the NFS server availability for the dom0's to be working, and also I could use a single copy of the rootfs for all dom0's, and no problem with a shared /tmp or /etc and so on.

While I can still see the advantages of using this style solution (NFS root), I think there are better options today (that I haven't investigated/used). One issue with the shared NFS root was also dealing with updates/upgrades, where my current solution handles that (chroot, install new package, reboot dom0 one at a time with appropriate live migrations). Today, with all the fancy management tools like puppet/chef/etc (I know nothing about them, except I vaguely understand they should support booting and installing/configuring your dom0, including any update/upgrades on each reboot). You might want to look into some of those options.

Of course, none of that directly helps you with your issue.

Have you tried getting shell access early in the init process, and measuring/testing what is actually wrong, is it CPU performance, network performance, or NFS performance? Possibly there is a network card driver issue, have you tried a different network card (different brand/model/etc)? What about your switch, does it report any collisions, dropped packets, errors, etc? Faulty network cable perhaps?

Sorry I couldn't help really, but maybe it will provide some ideas.


On 21/07/15 09:24, Brandon Perez wrote:
Hello All,

    Here's a quick overview of my setup:
    - Hardware: TI DRA72 Chip, Arm Cortex A15
    - Xen:
        - Version: 4.6-unstable
        - Compiled from source, with some local changes
        - Branch: master
        - Commit: ecdae1cfaa7f6123decaa1b9d7205c3ff726b941
        - Repo URL: git://xenbits.xen.org/xen.git
    - Linux Kernel:
        - Version: 3.14
        - Compiled From source, with some local changes
        - Branch: android-3.14-6AL.1.0
        - Commit: 7b2f1133857414b96927c06f08ed6c440f5472e7
        - Repo URL: git://git.omapzoom.org/kernel/omap.git

I'm attempting to get an root NFS boot working with a Linux Dom0. The boot works, but is horrendously slow. A /bin/sh boot takes several minutes, and an init boot takes hours (I gave up on init after 20 minutes). For comparison, a boot from an SD card takes about 15 seconds. Also, with a native Linux root NFS boot, the total boot time is about 25 seconds, so the issue seems to be related with Xen or my Xen configuration.

I haven't done a lot of debugging yet, so I don't have much additional information. Before I go deep into debugging this, I was wondering if this is an issue you guys have heard of before. Also, I was wondering if there was any immediate things you can think of that might be causing this problem.

One thing I have quickly looked over is /proc/interrupts. For a native boot, there are several hundred ethernet transmit interrupts. On the Xen boot, there are several million transmit interrupts.


    Brandon Perez

Xen-users mailing list

Adam Goryachev Website Managers www.websitemanagers.com.au

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.