[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XSM Error: File '/boot/flask/xenpolicy.24' not found

On Sun, 2015-09-06 at 22:29 +0800, big strong wrote:
> Hi, everyone. I configured XSM and install xenpolicy on Xen 4.4.3 with 
> the help of 
> http://wiki.xenproject.org/wiki/Xen_Security_Modules_:_XSM-FLASK. But 
> when I reboot the kernel, it stucks at Error: File 
> '/boot/flask/xenpolicy.24' not found. The xenpolicy.24 file is indeed 
> under the directory /boot/flask. I've tried to install the policy file in 
> /boot, still not work. Any suggestions?

I /boot a separate filesystem? The bootloader requires a path relative to
the filesystem/partition since it doesn't see Linux's view of the mount
points etc.

IOW if /boot is a separate fs then what Linux sees as
/boot/flash/xenpolicy.24 will appear to the bootloader as
/flash/xenpolicy.24 in the partition containing the /boot filesystem.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.