[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] "xl create" hangs


Thank you very much.Â

The xenstore process is running. The output ofÂxenstore-ls -f is attached for your reference.

Accidentally, with "xl create", we got one vm listed (as shown bellow).ÂHowever, the Mem and VCPUS are both 0. We think there is no problem with the configure file "xen2.cfg". Because in another server, we can launch the VM with the same configure file.Â

root@ubuntu:~# xl list
Name            ÂID  Mem VCPUs State Time(s)
Domain-0 Â Â Â Â Â Â Â Â Â Â 0 14692 Â Â 8 Â Â r----- Â Â 269.0
xen2 Â Â Â Â Â Â Â Â Â Â Â Â 1 Â Â 0 Â Â 0 Â Â --p--- Â Â Â 0.0

We did follow the same process to build and install XEN in two servers. In the first one, it works. But in the second one, we are encountering errors as described as above. Thank you very much for your help.

Wen QI

On Fri, Sep 11, 2015 at 3:25 AM, Ian Campbell <ian.campbell@xxxxxxxxxx> wrote:
On Thu, 2015-09-10 at 18:31 -0400, QI Wen wrote:
> Hi, all,
> Just now, updated the XEN debug level to "all" and tried "xl -v
> create" again, still no output except "Parsing config from xen2.cfg".
> But I found that, with "dmesg", I got "task xenconsoled:1218 blocked
> for more than 120 seconds." and "task xl:1370 blocked for more than
> 120 seconds.", as shown in bellow. The complete log can be found in
> the attachments.

Is there a xenstored process running?

> Logs with "xl dmesg" are also attached, in which many logs like
> "(XEN) traps.c:2514:d0 Domain attempted WRMSR *** from *** to ***"
> are found.

Those are expected with a pvops kernel.


Attachment: xenstore-ls-f.txt
Description: Text document

Attachment: xen2.cfg
Description: Binary data

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.