[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xl devd won't start in DomU: failed to get own domid


I'm successfully running my debian system with Xen 4.4 for more than
two years now. When trying to upgrade to the recent 4.6 release I ran
into a problem with the network driver domain.

As Xen 4.6 requires devd to run in a driver domain, I tried to start
it there but it fails:

root@svc-fw:~# xl devd -F
libxl: error: libxl.c:3864:libxl_device_events_handler: unable to get
domain id

Strange thing is that 'xenstore-read domid' outputs the domid without
any problems.

I get this error with Xen 4.6.0 and also with 4.4.1. I did a lot
lot of research and testing and still can't figure out why xl has
these problems while xenstore-read hasn't.

Perhaps someone can give me a hint where to look?

Ruediger Otte

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.