[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xl devd won't start in DomU: failed to get own domid

On Sun, Apr 24, 2016 at 01:41:34PM +0200, Rüdiger Otte wrote:
> Hi,
> I'm successfully running my debian system with Xen 4.4 for more than
> two years now. When trying to upgrade to the recent 4.6 release I ran
> into a problem with the network driver domain.
> As Xen 4.6 requires devd to run in a driver domain, I tried to start
> it there but it fails:
> root@svc-fw:~# xl devd -F
> libxl: error: libxl.c:3864:libxl_device_events_handler: unable to get
> domain id
> Strange thing is that 'xenstore-read domid' outputs the domid without
> any problems.

It is indeed quite weird, xl does exactly the same as 'xenstore-read domid' 

Can you paste the configuration file of your driver domain? Also, do you 
have driver_domain=1 in your configuration file? (although AFAICT the 
error for not having driver_domain=1 should be different than the one you 
are getting).


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.