[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen doesn't work with Adaptec ASR-72405

  • To: Xen-users@xxxxxxxxxxxxx
  • From: domain@xxxxxxxx
  • Date: Fri, 07 Apr 2017 16:20:15 +0300
  • Delivery-date: Fri, 07 Apr 2017 13:21:21 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>


I'm trying to find out the reason of the next problem:
after Xen booting, the system can't find RAID controller Adaptec ASR-72405 and as a consequence can't find SSDs. The module (aacraid) for this type of controller loaded. We have tried to boot with system installed (1.2-1[41010]-ms) and with the last Adaptec driver version (1.2.1-52033) from official site, but got the same result.

In dmesg we got few errors related with controller driver:

[ 1127.197227] aacraid: aac_fib_send: first asynchronous command timed out.
[ 1127.197227] Usually a result of a PCI interrupt routing problem;
[ 1127.197227] update mother board BIOS or consider utilizing one of
[ 1127.197227] the SAFE mode kernel options (acpi, apic etc)

But, when we have tried to boot the system without Xen, we don't have this problem.
The system have found the controller and all connected drives.
The drivers, kernel and other parameters of system have not been changed (the same with Xen system).

Some information about hardware and software versions:

Supermicro X10QBi, Version 3.0, Build Date 05/04/2016 12:38:52
CPUs 4x Intel (R) Xeon (R) CPU E7 -8890 v4 @ 2.20GHz
RAM 6291456 MB (DDR4 1600MHz)

Ubuntu kernel version: 4.4.0-67
Xen version: 4.6.0
RAID Controller Adaptec - 72405
Controller driver versions: 1.2-1[41010]-m, 1.2.1-52033
Controller BIOS version: BIOS: 7.5-0 (32106)
Controller Firware Version: Firmware: 7.5-0 (32106)

Xen boot log attached.

Attachment: 2017.04.07-data2-1.txt
Description: Binary data

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.