[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] [BUG] PCI-Passthrough Win7 / win10 -> code 10 / code 43

  • To: xen-users@xxxxxxxxxxxxxxxxxxxx
  • From: De.Morgan@xxxxxx
  • Date: Wed, 13 Dec 2017 18:37:12 +0100
  • Delivery-date: Wed, 13 Dec 2017 19:53:39 +0000
  • Importance: normal
  • List-id: Xen user discussion <xen-users.lists.xenproject.org>
  • Sensitivity: Normal

Hey there,

I'm working with Xen as a designer of a Continuous
Integration System. Basically the chain is: Jenkins
-> Libvirt -> Xen => different Ubuntu/Windows => PCIPassthrough ->
USB-Hardware to test. How ever, the setup is working great for Ubuntu
16.04 and WinXP. I can pass through my PCIe-USB3.0 Card to the DomU
and it is recognized and all plugged in USB-Devices are working like a

Trouble has made me windows 7/10. I've tried to pass 5 different PCIe-
Chips to the VM. The results are the following: Non of the tested
PCIe-Cards brought up a working device. They more or less showed all
up in Device manager and were found by the driver come from its
vendor. Some of them showed up normal, but any connected device to the
PCIe-Cards showed up with a Error 43 "Winbdows has stopped the device,
because it has reported problems, USB-Port reset failed" Some PCIe
show up, but produce Errorcode 10 "An invalid parameter was passed to
a service or function"/"Error in starting the device"

## Errorinvestigation

Hardware is a dell precision tower 3620 intel i7 7700

# Tried: Dom0 Umubtu 17.10, Xen 4.9 and libvirt from apt With all
combinationes of 5 PCIe Cards and win7/10

# Logs are from following setup
(was setup for investigating the error):

Dom0 Ubuntu 16.04 r3
sudo apt-get install -y xen-hypervisor-4.6-amd64
sudo apt-get install -y libvirt-bin
sudo apt-get install -y virt-manager
start klicking the machine together in virt-manager,
 * fullwirt
 * see details in dumpxml from libvirt
 * running install setup of win10 (90day trail version)
 * rebooting the machine with Passthrough USB-Device

DomU (win10v6, see xmldump from libvirt):
    Win10 from a free avariable Image from Microsoft
    (90-day-test-version) 14393.0.160715-1616.RS1_RELEASE_ \
tested before and after installation of PV-Drivers 8.2 (no difference)

# Tested PCIe Devices
 * TI: TUAB 7340 RKM TI 35I AVFQ 64;
     code 43 for all plugged in devices
 * Renesas: 2xUSB: D720202 701 1245PV049G CHINA
     code 10
 * Renesas: NEC JAPAN; D720200F1;
 * Etrontech EJ168A R144207 MQR30020 (rev 01);
     code 43 for all plugged in devices
 * ViaTechnologies Host controller VL805;
     appears, but is silent according to any plugge in USB-Device
Errorcodes are from Windows Device Manager
All Cards are working in native systems. As a USB-testdevice there
was a DELL Keyboard and a USB-Pendrive used

## Questiones:
Is this error known, or has sombody already tested a
setup like this and it has worked? Is there a flag to set, or do the
windows machines need some more configuration? What can I do to
investigate in the error? What caused the error, is this windows, is
this Xen, is this my Desktop or probably libvirt? Is there a better
way in doing it, probably without libvirt?

thx for reading, I'm happy to support every Idea!

Attachment: Win7-10_PCI-PassThrouge.tar.gz
Description: Binary data

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.