[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen on hikey board --xen booted, but can not setup dom0 guest OS

(+ Konrad and Stefano)


On 06/02/18 23:47, ls00722 wrote:
    I am hopping someone can give me a hint as I am brand new to xen. Here is
the boot log:

Shell> xen
Xen 4.11-unstable (c/s Thu Nov 9 12:15:00 2017 +0100 git:ec32054) EFI loader
Using configuration file 'xen.cfg'
hi6220-hikey.dtb: 0x000000007ac93000-0x000000007ac9c786
Image: 0x00000000796bc000-0x000000007ac87a00
  Xen 4.11-unstable
(XEN) Xen version 4.11-unstable (leisun@) (aarch64-linux-gnu-gcc (Linaro GCC
7.2-2017.11) 7.2.1 20171011) debug=y  Wed Dec 20 00:23:59 PST 2017
(XEN) Latest ChangeSet: Thu Nov 9 12:15:00 2017 +0100 git:ec32054
(XEN) Processor: 410fd033: "ARM Limited", variant: 0x0, part 0xd03, rev 0x3
(XEN) 64-bit Execution:
(XEN)   Processor Features: 0000000000002222 0000000000000000
(XEN)     Exception Levels: EL3:64+32 EL2:64+32 EL1:64+32 EL0:64+32
(XEN)     Extensions: FloatingPoint AdvancedSIMD
(XEN)   Debug Features: 0000000010305106 0000000000000000
(XEN)   Auxiliary Features: 0000000000000000 0000000000000000
(XEN)   Memory Model Features: 0000000000001122 0000000000000000
(XEN)   ISA Features:  0000000000011120 0000000000000000
(XEN) 32-bit Execution:
(XEN)   Processor Features: 00000131:00011011
(XEN)     Instruction Sets: AArch32 A32 Thumb Thumb-2 Jazelle
(XEN)     Extensions: GenericTimer Security
(XEN)   Debug Features: 03010066
(XEN)   Auxiliary Features: 00000000
(XEN)   Memory Model Features: 10101105 40000000 01260000 02102211
(XEN)  ISA Features: 02101110 13112111 21232042 01112131 00011142 00011121
(XEN) Using PSCI-1.0 for SMP bringup
(XEN) SMP: Allowing 8 CPUs
(XEN) Generic Timer IRQ: phys=30 hyp=26 virt=27 Freq: 1200 KHz
(XEN) GICv2 initialization:
(XEN)         gic_dist_addr=00000000f6801000
(XEN)         gic_cpu_addr=00000000f6802000
(XEN)         gic_hyp_addr=00000000f6804000
(XEN)         gic_vcpu_addr=00000000f6806000
(XEN)         gic_maintenance_irq=25
(XEN) GICv2: 160 lines, 8 cpus, secure (IID 0200143b).
(XEN) Using scheduler: SMP Credit Scheduler (credit)
(XEN) Allocated console ring of 64 KiB.
(XEN) Bringing up CPU1
(XEN) CPU 1 booted.
(XEN) Bringing up CPU2
(XEN) CPU 2 booted.
(XEN) Bringing up CPU3
(XEN) CPU 3 booted.
(XEN) Bringing up CPU4
(XEN) CPU 4 booted.
(XEN) Bringing up CPU5
(XEN) CPU 5 booted.
(XEN) Bringing up CPU6
(XEN) CPU 6 booted.
(XEN) Bringing up CPU7
(XEN) CPU 7 booted.
(XEN) Brought up 8 CPUs
(XEN) P2M: 40-bit IPA with 40-bit PA and 8-bit VMID
(XEN) P2M: 3 levels with order-1 root, VTCR 0x80023558
(XEN) I/O virtualisation disabled
(XEN) build-id: 6aeb25858ed490b5736cdaa6a3951d3500a9807d
(XEN) alternatives: Patching with alt table 00000000400bced0 ->
(XEN) grant_table.c:1680:IDLEv0 Expanding d0 grant table from 0 to 1 frames
(XEN) Loading kernel from boot module @ 00000000796bc000
(XEN) Allocating 1:1 mappings totalling 512MB for dom0:
(XEN) BANK[0] 0x00000040000000-0x00000060000000 (512MB)
(XEN) Grant table range: 0x0000007fa00000-0x0000007fa40000
*(XEN) IRQ 71 is already used by Xen
*(XEN) Unable to map IRQ71 to dom0**

IRQ 71 is a UART interrupt which, I guess, belongs to the UART used by Xen. A brief look at the upstream DT, this should not be shared with any other device.

Did you modify the DT?

(XEN) Device tree generation failed (-16).
(XEN) ****************************************
(XEN) Panic on CPU 0:
(XEN) Could not set up DOM0 guest OS
(XEN) ****************************************
(XEN) Reboot in five seconds...

I used exact kernel version from wiki article(4.1) and also tried a newer
kernel version (4.9), they have the same result. Besides if I don't boot
xen, but do the default Linux boot, it stucked at:
*/EFI stub: Exiting boot services and installing virtual address map.../*

I have CCed Stefano and Konrad who are using that platform. They may be help to you.


Julien Grall

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.