[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Fwd: dom0=pvh and 4.18

On Sun, Aug 12, 2018, 8:32 PM Glenn Enright <glenn@xxxxxxxxxxxxxxx> wrote:
Hi all,

Doing some testing with 4.18 kernel, trying to get dom0=pvh working with

Builds are from my own test machine, with a gcc8.0 toolchain for
centos6. Test machine is a Supermicro X9 board with Dual E52630v2 cpus.

What I'm seeing is that xen boots up fine, but on the transition to the
linux kernel, the screen goes blank and the server never pings. I've
tried a bunch of different command line options including various
console/serial with no change.

Does anyone have a magical set of xen boot options that could help get
me started or at least show something to point the way?


Xen-users mailing list

Glenn! I had some issues getting Dom0 to boot up as well. My initramfs requires a password entry, and such was not allowed by my initial setup. I feel your pain.

Lemme share what got me off the ground, in case it has something you haven't tried.

In the grub.cfg:

multiboot    /xen.gz dom0_mem=2048M.max:4096M iommu=no-igfx ucode=scan

module /vm-linuz-4.17.13-gentoo {stuff specific to my setup that I doubt we have in common} softlevel=xen console=tty quiet vt.handoff=3 

The "console=tty" was important for me. And vt.handoff=3 for a console-booting system. vt.handoff=7 if it boots directly into a DE.

And now you've got me curious about how to replicate your success. Where is the Dom0 config file where I can add "type=pvh"? Was there more involved than what you've already mentioned?
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.