[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building for unix backend fails

Will do Anil, anyway, as of yesterday evening everything worked without issues.

For "unix-direct" it would be handy to be able to specify more than one interfaces using Mirari and use incremental "tapX"  as netif ID, instead of tap0, and assign it a non hard-coded IP address:

Also, I will share an updated/enhanced version of the following script:
and similar VM-uninstall script


On 19/07/13 15:36, Anil Madhavapeddy wrote:
Dimos: try with the latest rounds of changes, as everything should be consistent again.  Also, let us know if you need anything extra in Mirari while you set up your cluster.


On 18 Jul 2013, at 15:08, Dimosthenis Pediaditakis <dimosthenis.pediaditakis@xxxxxxxxxxxx> wrote:

Hi Richard,
I reinstalled everything from scratch all of a sudden it worked :-o

Anil, thanks for your response.

I am aiming to port SDNSim in Xen, but as a first step, I experiment with simple Mirage apps with networking.

I test it under Linux  3.5.0-36, using opam 1.0.0.
I've added mirage/opam-repo-dev as a remote to opam
I use mirari to build the projects (which I find extremely convenient).

Still have the issue with the "tcp" example not running on Xen, but I will keep working on it  (not an easy thing to debug Xen guests).
If I have no luck, I might ping you again.


On 18/07/13 13:48, Richard Mortier wrote:
forgot to hit reply-all...

Begin forwarded message:

From: Mortier Richard <pszrmm@xxxxxxxxxxxxxxxxxxxxxxx>
Subject: Re: Building for unix backend fails
Date: 18 July 2013 13:48:28 GMT+01:00
To: Dimosthenis Pediaditakis <dimosthenis.pediaditakis@xxxxxxxxxxxx>

hi dimos;

On 18 Jul 2013, at 13:39, Dimosthenis Pediaditakis wrote:

Build the "static_website" from the "mirage-skeleton" examples fails:
Building executable mir-hello
[1 of 3] Compiling Hello                         [2 of 3] Compiling Backend
File "backend.ml", line 19, characters 45-58:
Error: Unbound constructor OS.Netif.PCAP
[mirari] ERROR: The command "obuild build" exited with code 6.
make: *** [build] Error 1

odd - i just copied static_website as the basis for the oscon presentation, and it builds and runs just fine for me using unix-socket-build and unix-direct-build as targets.

i did do a clean reinstall of opam and everything yesterday though, while tweaking installation wiki pages, although i currently have the same versions of all the opam packages you listed.

what are you doing to build it?  is your code in a repo somewhere?







Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.