[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MirageOS-devel] Struggling a bit with the Hello World applications

On 5 May 2014, at 17:09, André Næss <andre.naess@xxxxxxxxx> wrote:

> I just made two new attempts. I first tried on Ubuntu 14.04 and then on 
> 12.04. Both failed, but for different reasons. 
> I have to admit that I'm getting a bit frustrated now. It seems that changes 
> are pulled down immediately making the environment very unstable. Is there 
> some kind of mechanism for ensuring that I get a stable repeatable 
> environment where I control when I want to try to upgrade the various 
> packages (provided I can get it to work)?

There is.  Just "git clone git://github.com/ocaml/opam-repository" to get a 
local copy of the repository, and then "opam init <path-to>/opam-repository".  
To update, git pull to the new revision and then issue an "opam update" (with a 
-u if you want to upgrade, or a separate "opam upgrade").

> Below is what happened:
> On 14.04 I got this while running opam init:
> ERROR] The compilation of base-bigarray.base failed.
> [ERROR] The compilation of base-threads.base failed.
> [ERROR] The compilation of base-unix.base failed.
> ===== ERROR while installing base-bigarray.base =====
> Internal error:
>   Sys_error("rm -rf /home/vagrant/.opam/system/lib/base-bigarray: Cannot 
> allocate memory")
> ===== ERROR while installing base-threads.base =====
> Internal error:
>   Sys_error("rm -rf /home/vagrant/.opam/system/lib/base-threads: Cannot 
> allocate memory")
> ===== ERROR while installing base-unix.base =====
> Internal error:
>   Sys_error("rm -rf /home/vagrant/.opam/system/lib/base-unix: Cannot allocate 
> memory")

To ask the obvious question: how much memory does this VM have?

I just tried reproducing this on a fresh Ubuntu 14.04 VMWare Fusion:

$ sudo apt-get install opam ocaml-native-compilers camlp4-extra ocaml
$ opam init
$ opam install mirage
$ git clone git://github.com/mirage/mirage-skeleton
$ eval `opam config env`
$ cd mirage-skeleton
$ make MODE=xen console-build

And everything worked as expected with a Xen unikernel, so I can't reproduce 
your situation.  

> I then went back to the 12.04 install. This time I got everything up and 
> running and tried to compile the console example. It took a very long time, 
> but it built. Unfortunately it also uninstalled mirage. Here's the log:

That's clearly going wrong as well, due to the internal heuristic.  Is this 
using OPAM 1.1.1?


MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.