[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] pv_ops dom0 kernel failure with ata_piix

Pasi Kärkkäinen wrote:
On Tue, Dec 30, 2008 at 08:18:45PM +0200, Pasi Kärkkäinen wrote:
On Tue, Dec 30, 2008 at 06:52:11PM +0200, Pasi Kärkkäinen wrote:
On Tue, Dec 30, 2008 at 11:47:40AM -0500, Todd Deshane wrote:
On Tue, Dec 30, 2008 at 11:28 AM, Pasi Kärkkäinen <pasik@xxxxxx> wrote:
Try changing the SATA mode of the disk in the BIOS to either legacy or
ATA, depending
on what you bios supports.

There is still a known issue with some of the AHCI stuff.

I'm not using AHCI at all.. AHCI (SATA) controller does not have any disks
plugged in.

My (only) disk is attached to IDE/PATA ICH6 controller..

I tried disabling AHCI anyway (even when I'm not using the AHCI SATA
controller), but it didn't help.

Booting the pv_ops dom0 kernel still fails.. because the IDE/PATA controller
still gets disabled (just like in the logs above) for some unknown reason.

-- Pasi
So from the log it looks like you are getting a hard crash?

No, it's not a hard crash.. I'm able to reboot the box with ctrl-alt-del.
Did you try adding noreboot to the xen command line and then trying
to get any more information with sysreq stuff?

Another thing that I noticed in the log is:

irq 12: nobody cared (try booting with the "irqpoll" option)

Is it an smp kernel? I had some weird problems when passing nosmp at
one point.

Yep, it is SMP kernel..
I don't recognize this crash, those module traces, at least for me were
non-fatal and didn't cause a crash. I was normally just dropped to a
initramfs prompt in the case when the disk was not detected properly.

I was then able to at least look around and check that modules were
loaded correctly etc.

The problem seems to be the IDE controller/disk is not detected at all..
because the device gets disabled for some reason during ata_piix
That is the only disk I have, so the root partition is on it.

Same kernel works just fine on baremetal without Xen.

So I guess the subject should be 'failure with ata_piix' instead of 'crash'..
Anyway, there seems to be problems with ata_piix too.. in addition to AHCI.

Jeremy: Can you think of anything to try?

I tried booting with "nosmp" dom0 kernel parameter:

Yes, nosmp is known to make things worse. It has the side-effect of disabling io_apic support, so all the interrupt stuff fails in the way you've noticed.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.