[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [RFC PATCH v2 2/3] arch, arm: add the XEN_DOMCTL_memory_mapping hypercall

>>> On 13.03.14 at 16:51, Dario Faggioli <dario.faggioli@xxxxxxxxxx> wrote:
> On gio, 2014-03-13 at 15:36 +0000, Jan Beulich wrote:
>> >>> On 13.03.14 at 16:29, Ian Campbell <Ian.Campbell@xxxxxxxxxx> wrote:
>> > "foo + foo_mfns" appears quite a lot here. I think you could calculate
>> > those once into foo_start and foo_end and use throughout which would
>> > make the remainder much easier to follow.
>> > 
>> > Oh, I see this came from the x86 function of which this is an almost
>> > complete copy -- can it not be made common?
>> > 
>> > The difference seems to be map_mmio_regions vs. a loop over
>> > set_mmio_p2m_entry which seems easy enough to abstract out.
>> Indeed.
> But, if I can ask, from where does this difference come from? If Arianna
> is to make this common code, should she retain such difference or kill
> it? I mean, do we want to keep having x86 mapping in loop and ARM
> mapping all at once, or can we just merge that part two? If the former,
> why?

For one I'm the wrong one to ask - I didn't write that code.
And second - map_mmio_regions() is (so far) an ARM specific
function. Hence perhaps putting the loop into an identically
named function on x86 would be the right thing to do?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.