[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH] xen: Use #defines instead of magic constants in vmx_vmcs_save()



>>> On 05.08.14 at 11:57, <rcojocaru@xxxxxxxxxxxxxxx> wrote:
> --- a/xen/arch/x86/hvm/vmx/vmx.c
> +++ b/xen/arch/x86/hvm/vmx/vmx.c
> @@ -434,7 +434,8 @@ static void vmx_vmcs_save(struct vcpu *v, struct 
> hvm_hw_cpu *c)
>      c->error_code = 0;
>      __vmread(VM_ENTRY_INTR_INFO, &ev);
>      if ( (ev & INTR_INFO_VALID_MASK) &&
> -         hvm_event_needs_reinjection((ev >> 8) & 7, ev & 0xff) )
> +         hvm_event_needs_reinjection(MASK_EXTR(ev, INTR_INFO_INTR_TYPE_MASK),
> +            ev & INTR_INFO_VECTOR_MASK) )

Broken indentation, but I guess I can fix this up while committing
unless the VMX maintainers dislike the change and don't give their
ack.

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.