[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] FW: PCI and VGA Passthrough regressions on Xen 4.4.1 vs 4.3.2

Some further tests:

0 - Replacing the hvmloader from Xen 4.4.1 with the one from 4.3.2 (File 
/usr/lib/xen/boot/hvmloader) produces same results with the Sound Card. So it 
is not the hvmloader, either.
A thing with I think that COULD be, assuming it is not Xen itself, is that on 
Xen 4.3.x the Linux Sound Card Driver starts and grab the device before 
xen-pciback, so it effectively initializes it before xen-pciback makes it 
available for DomU use, which is the workaround that allows me to get it 
working on 4.4.1. As I don't know the order that they currently start I don't 
know if that's possible, but I suppose that it could be tested by blacklisting 
the Sound Card Drivers in Xen 4.3.2, which should produce the same horrible 
sound that happens on Xen 4.4.1 if that were the case.

Also, I have been experimenting a bit with VGA Passthrough, with no success on 

1 - First thing I did, was to try to reproduce allowing Dom0 Driver grab the 
GPU, then using xl pci-assignable-add. I removed the Radeon PCI Address 
(01:00.0 and 01:00.1) from xen-pciback. After that, trying to use xl 
pci-assignable-add 01:00.0 nearly instantaneously freezes the Dom0 (Blinking 
cursor jumps a line before freezing and that's all), in both 4.3.2 and 4.4.1. 
This seems to be rather normal cause the GPU is not intended to be unpluggable 
like that if the radeon Driver has it.

2 - After checking some VGA Passthrough guides, many said to blacklist the 
radeon Driver, which after checking with lsmod | grep radeon I had running. So 
I added the modprobe.blacklist=radeon line for the Kernel in the Boot Loader 
config, which seemed quite straightforward compared to remaking the initramfs 
image. This effectively seemed to remove it, cause lsmod | grep radeon gave no 
results anymore. If using xl pci-assignable-add 01:00.0, there were no freezes 
or anything abnormal, just a warning than it was unbinded with no Drivers 
claiming it.

3 - The WXP DomU was left in a functional state while running Xen 4.3.2. After 
installing the Catalyst Drivers (Without CCC) and rebooting the DomU, the 
Radeon appeared but with a yellow exclamation mark. I think it was Error 22 if 
I recall correctly, complaining about resources. Solved by disabling the 
emulated Cirrus and rebooting. At this point, the Monitor connected to the 
Radeon finally turned on during WXP booting sequence. I don't recall if I did a 
few reboots to confirm it works consistently, cause I didn't builded 4.3.2 with 
the ATI Passthrough patch.
This same DomU failed to boot with 4.4.1. At first it seems the Radeon Fan 
starts to work, but the Monitor doesn't get signal and the DomU SDL Window in 
Dom0 is just a black screen. After a while, it BSODs complaining the ati2dvag 
Driver, the error message includes something about an infinite loop and some 
error codes I didn't paid attention.

4 - After that BSOD, killing the DomU and trying to create it again causes a 
hard freeze of Dom0. Repeated several times, results seems consistent. Monitor 
doesn't ever get signal.

5 - Rebuilded Xen 4.4.1 with the ATI Passthrough patch from 4.3.x that is still 
included in the Arch Linux xen package and builds, but is claimed to be 
untested. Results are the same as previously described.

So basically, VGA Passthrough on Xen 4.4.1 has been unusable in my system, 
while the PCI Passthrough issue could at least be workarounded. Didn't bothered 
to get a blob of logs of my VGA Passthrough tests cause I doubt they would be 
useful or that there is manpower for that - chances are that it may be more 
wise to see if PCI Passthrough can be fixed first because its easier, VGA 
Passthrough seems to have been always taking on goliath with a slinger, so I 
don't have hopes that it could be fixed anytime soon.

Teo En Ming reported not so long ago that he got VGA Passthrough working in a 
not-so-different system: Linux Kernel 3.16, Xen 4.4.1, major difference would 
be an Ubuntu Dom0 and a Radeon 6450. However, he was using a Windows 7 DomU: 
As I didn't tested VGA Passthrough with any other OS, I can't say if the 
Catalyst Drivers could be at fault. I'm using the Catalyst 12.1 for WXP cause 
they were the last ones to include OpenCL support and worked in 4.3.2. Could 
try with latest Drivers and/or Windows 7 if you really suggest so. Would be 
looking at his install instructions to check if I am not missing something.

Also, you may be interesed in a theory I have about the famous "performance 
degradation" with Radeons: 
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.