[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xc_altp2m_set_vcpu_enable_notify fail

I'm still not very clear why would do_altp2m_op change the domain to current domain (which is dom0 in my case) when the cmd is HVMOP_altp2m_vcpu_enable_notify. As to my case, it would prevent the dom0 to set the #ve info page for other domUs because the check of is_hvm_domain would fail and the function will returns directly.

2016-05-12 0:26 GMT+08:00 Sahita, Ravi <ravi.sahita@xxxxxxxxx>:

Hi Fangtuo,


#VE can be setup to be delivered to any dom that is a HVM.




From: Big Strong [mailto:fangtuo90@xxxxxxxxx]
Sent: Wednesday, May 11, 2016 8:38 AM
To: Wei Liu <wei.liu2@xxxxxxxxxx>
Cc: Tamas K Lengyel <tamas.k.lengyel@xxxxxxxxx>; Sahita, Ravi <ravi.sahita@xxxxxxxxx>; Xen-devel <xen-devel@xxxxxxxxxxxxx>
Subject: Re: [Xen-devel] xc_altp2m_set_vcpu_enable_notify fail


Is that a bug or does #ve info page can only exist on dom0? If this is true, why would there be a is_hvm_domain check which will stop the execution of xc_altp2m_vcpu_enable_notify?


2016-05-11 15:56 GMT+08:00 Big Strong <fangtuo90@xxxxxxxxx>:

From what I analyzed, can I draw a concolusion that the current implementation of do_altp2m_op means #ve info page can only be set on dom0 memory and the dom0 must be a hvm? This seems like ridiculous as dom0 is a special pv guest.


2016-05-11 11:37 GMT+08:00 Big Strong <fangtuo90@xxxxxxxxx>:

Further debugging shows that the domain is changed to domain 0 during the check of whether the cmd of do_altp2m_op is HVMOP_altp2m_vcpu_enable_notify, located at here. As domain 0 is a pv guest, it causes the is_hvm_domain check failed, and thus the execution never goes to HVMOP_altp2m_vcpu_enable_notify, which in the end cause xc_altp2m_set_vcpu_enable_notify fail. Why would the logic of do_altp2m_op change the domain to dom0 when the cmd of do_altp2m_op is HVMOP_altp2m_vcpu_enable_notify?


Thanks for the suggestion, after adding printk to all the routines of xc_altp2m_set_vcpu_enable_notify, it turns out that the problem is because the check of is_hvm_domain() failed in function do_altp2m_op(). However, I've already configure the VM to build as a HVM by adding option "builder=hvm" in the config file, but for unknown reason the .printk of domain->type is guest_type_pv. I've tried both windows and linux as the guest VM, both failed for the same reason. Any ideas?

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.