[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 2/2] x86/msr: Rename the msr policy objects

>>> On 09.07.18 at 12:29, <andrew.cooper3@xxxxxxxxxx> wrote:
> After attempting to develop the infrastructure, it turns out that the choice
> of naming is suboptimal.
> Rename msr_domain_policy to just msr_policy to mirror the CPUID side of
> things, and alter the 'dp' variable name convention to 'mp'.  While altering
> all the names, export all of the system msr_policy objects (which are already
> global symbols).
> Rename msr_vcpu_policy to vcpu_msrs and switch 'vp' to 'msrs' in code.  Update
> the arch_vcpu field name to match.
> No functional change.
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>

Acked-by: Jan Beulich <jbeulich@xxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.