[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Very slow domU network performance

I set up a domU as a backup server, but it has very, very poor network performance with external computers. I ran some tests with iperf and found some very weird results.

Using iperf, I get these approximate numbers (the left column is the iperf client and the right column is the iperf server):
domU --> domU  1.77 Gbits/sec (using
domU --> domU  1.85 Gbits/sec (using domU eth0 IP address)
dom0 --> domU  91.5 Mbits/sec
domU --> dom0  85.2 Mbits/sec

So far, so good. The relatively slow dom0<->domU communication may indicate a problem, but it's fine for my purposes. The real problem is when I use my iBook (running Mac OS X) to run some iperf tests. The computers are connected via a crossover cable. They were originally connected with a hub, but I changed to a crossover cable connection to reduce variables (it turns out this had no effect).

dom0 --> iBook  89.0 Mbits/sec
iBook --> dom0  86.9 Mbits/sec
domU --> iBook 87.1 Mbits/sec
iBook --> domU 1.87 Mbits/sec

The last entry has me baffled. Why would it be so incredibly slow in one direction but not the other?

I decided to run some UDP tests as well.
server: iperf -s -u -i 1
client: iperf -c server_ip -u -b 90M -t 5
The packet loss is as follows:
domU --> domU  0% (using
domU --> domU  0% (using domU eth0 IP address)
dom0 --> domU  ~100% (only 7 of 38464 made it!)
domU --> dom0  0.09%

dom0 --> iBook  4.7%
iBook --> dom0  0.33%
domU --> iBook  11%
iBook --> domU  1.6%

There are some odd things here. First, dom0->domU with UDP loses almost everything, but the reverse direction is fine. Somehow, dom0- >domU TCP was OK (if you consider ~90Mbps OK). The second weird thing is that in contrast with TCP, UDP works fine in both directions between the iBook and domU. There's 11% packet loss in one case, but that's not a lot -- it's probably just a little more than poor little iBook can handle.

My dom0 is Fedora Core 5, with the included xen0 kernel. The domU is a very basic install of Centos 4.3, based on a jailtime.org image, running the xensource kernel. The domU has bridged networking and 64MB of RAM (I ran the iBook->domU TCP test with 196MB of RAM but it was still ~2Mb/s). Firewalling is off in domU and dom0; the only iptables rules are the ones created by the xen bridging script.

Has anyone else seen anything like this, or have any idea what's going on? This seems bizarre to me.
Thanks for any help.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.