[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Running Redhat Advanced Server 2.1 on hvm


I was trying to have a working RHEL2.1 domU and found a mail sent on January 26th to xen-users by Nelson Chan. I am subscribed to the list but didn't have the original mail in my mailbox, so I'm sending this message with the same subject. Sorry if I screw up you mail reader's threading algorithm :)

Anyway, after successfully installing a RHEL2.1 in hvm mode from our kickstart server, I tried two things:

- running with non-hvm using the 2.4 xenU kernel provided by xensource. The system would boot although the console was stuck on the last init script launched. The init process would give weird messages (sorry, I didn't wrote them down) but the system could be reached by ssh. Some binaries (yum for example) would segfault. The upgrade to RHEL3's glibc worked, but I didn't want to go that way...

- running with hvm and the default RHEL2.1 kernel. This didn't work and gave a kernel panic upon boot (I tried with -52 and the latest -71 release level from RH). I then took the vmlinuz and initrd files from the installation cd and used them. They are actually built from the same srpm and are found in the -BOOT package. I just had to tweak the initrd file so that it wouldn't launch the install after booting, but it worked.

I'm using the system with this setup. As soon as I'll have time, I'll diff the kernel config files to try and locate the option(s) that make the regular kernel crash.

Eric-Olivier Lamey

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.