[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Multiple IPs in a domU (I am using static macs)

Thanks very much for all the info Tim, but I'm still stumped. I don't know what to do next.

To clarify:

dom0 has an eth0 and an eth1, but I don't care about my domUs having access to dom0's eth0 - just eth1. And this is how it's working currently, in my xend-config.sxp file I have:

(network-script network-bridge netdev=eth1)

The only thing that *isn't* working is having more than one IP inside a domU. I've tried it using eth0:1 and eth1, inside the domU. (note that this mention of eth1 is separate from the dom0 eth1).

Does you or anyone else have any more specific suggestions on how to make multiple IPs workin in a domU? How can I get xen to just do for domU eth1 what it does for domU eth0?

For those new to thread, xen isn't arp announcing domU eth1's IP, but it is doing that for domU's eth0.

Dan Parsons

On Feb 26, 2007, at 4:05 AM, Tim Post wrote:

On Mon, 2007-02-26 at 11:39 +0000, Dan Parsons wrote:
Thanks for the suggestions.
Did something I say make you think I'm using a HVM? I'm using a plain old paravirtualized VM here.
Does this change any of your suggestions?

No, not at all. I just suspected everything would be effected. There are some known netdev quirks with hvm guests, was just pointing out to check
upstream before going after issues there too.

My worry about the ping fix is that if there is no traffic on that IP for a long time,
the arp record created by the ping will die.
And then the router issues another arp who-has, and we have the same problem. Indeed, it looks as if Xen is ignoring who-has requests for eth1's IP....

Also, how can it be upstream when the eth0 ip works just fine? It's just eth1's ip that's bad.

THAT's where I mis read you. I thought this was on a bridge porting

What is xen doing to make eth0 work, that it's not doing for eth1? And why?

The magic is happening in /etc/xen/scripts/network-bridge , which is run
to construct the bridges when xen starts and take them down / restore
things when xen exits.

Within xend-config, you can pass paramaters to it. I personally don't
use it, I like to let my network init scripts handle the bridges because
I do more with bridging than Xen needs to do.

Dan Parsons

Now it makes sense, and no , I don't think its upstream anymore. I'm
more dense than usual for some reason today.


-----Original Message-----
From: Tim Post <tim.post@xxxxxxxxxxxxxxx>
Date: Mon, 26 Feb 2007 19:30:21
Subject: [QUAR] Re: [Xen-users] Multiple IPs in a domU (I am using static macs)

On Mon, 2007-02-26 at 10:18 +0000, Dan Parsons wrote:
Thank you, but I actually am using statically defined MACs in the domU config.. So I don't believe what you said applies. Please correct me if I'm wrong.

Ah no, you're right I had a brainfart. Mac was staring right at me in
your config file.

Do you have further suggestions?

I haven't run into this, but only a few of my guests are HVM. You could
try a couple of things.

If you are using Xen's network-bridge script to bring up your bridges, try letting init do it and use a network-dummy script in its place, play
with the bridge settings and see if it helps.

forward delay, helo, maxwait, should be set to 0. I am not entirely sure
that they are set to 0 by default by brctl.

Or a quick fix, call ping during the boot process on the guest slightly modifying the init strings until you can rule out exactly what the issue

I'm tending to lean in the direction of something upstream, though.


Dan Parsons

-----Original Message-----
From: Tim Post <tim.post@xxxxxxxxxxxxxxx>
Date: Mon, 26 Feb 2007 18:05:53
To:Dan Parsons <dparsons@xxxxxxxx>
Subject: [QUAR] Re: [Xen-users] Multiple IPs in a domU

On Sun, 2007-02-25 at 21:54 -0800, Dan Parsons wrote:
I've been trying to make multiple public IP addresses work in a domU,
and have been unable to do it. I've tried every method mentioned in
the xenu-users archive as well as through a lot of stuff mentioned in

 Then the IP works. So,
it's a MAC/ARP issue.

Most cisco routers take up to ~9 minutes to re-arp these changes. Static
MACS must be used.

You could tri arping'ing the gateway just specifying the address and
interface (i.e. eth0:1) or pass a -U. This should trick the router into
doing it.

The best way, use static macs when bringing up the vifs within the
dom-u. Remember, you can have only 3 physical eth devices within a
guest, as far as I know this limitation has not yet increased.

So, its much easier to bring them up as vifs from within the dom-u
itself, just specify macs for each one.

But why isn't the MAC for eth1 being announced?

It is. apring is being called each time its brought to an up state to make sure the IP does not already exist on the network. You either have to wait 10 minutes, send traffic from it (i.e. ping -I eth0:1 -c1 -w5 > /dev/null 2>&1 in the postup init script. It really depends on
the router.

I've tried specifying
the IPs in the domU config various ways and that also didn't help.

That's not going to make much of a difference. I often just specify
bridge, vifname and mac and handle the rest inside of the guest.

This is on Fedora Core 6, using Xen 3.0.3. domU is also FC6 using the
same kernel. kernel is 2.6.19-1.2911.fc6xen. Below is a bunch more
info, please tell me if I've forgotten to include anything.

Just flushing the router's arp hehehe :)

domU config file:
,,, looked just fine to me.

[ snip ]

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.