[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] opensuse 10.3, xen 3.1, and raw devices

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Marlier, Ian" <ian.marlier@xxxxxxxxxxxxxxxxxxx>
  • Date: Tue, 9 Oct 2007 12:48:40 -0400
  • Delivery-date: Tue, 09 Oct 2007 09:49:41 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcgKlD4Kzt4dMl3NRPG8OqoM/l2aIA==
  • Thread-topic: opensuse 10.3, xen 3.1, and raw devices

Mornin', all --

For the past year or so, I've been taking advantage of the ability of
xen 3.0 to export a raw device to a domU in order to simplify machine
creation and management.  I create a "master" image on a standard ext3
partition, along with it's config file.  Then, to create a new machine,
I just have to do this:
- Create a new partition in dom0, create a filesystem on it, mount it,
and do a cp -ax from the Master image to the new partition.
- Using sed and mv, replace things like the hostname, MAC address(es),
ip address, etc in the new image and in the config file for the new
- Unmount the new partition, and start the machine.

This has worked very well -- management is simple, and by exporting the
master image via NFS I can install identical domU's on any amount of
host hardware within a matter of minutes.

However, I'm having trouble getting this configuration to work under Xen
3.1.0 (as packaged with opensuse 10.3).

Here's an example config file that worked under Xen 3.0.X:
disk = [ 'phy:/dev/xenmachines/Dale-GDS,hdb2,w',
'phy:/dev/xenmachines/Dale-GDS-swap,hdb1,w' ]
memory = 448
vcpus = 1
builder = 'linux'
name = 'Dale-GDS'
vif = [ 'mac=00:16:3e:ab:00:25, bridge=xenbr0' ]
localtime = 0
on_poweroff = 'destroy'
on_reboot = 'restart'
on_crash = 'restart'
extra = ' TERM=xterm'
bootloader = '/usr/lib/xen/boot/domUloader.py'
bootentry = 'hdb2:/boot/vmlinuz-xen,/boot/initrd-xen'

I tried using effectively the same config file, with a few additional
lines, but without success -- I end up getting the error message
"VmError: Had a bootloader specifed, but no disks are bootable".  Here's
an example modified config which is not working:
name = 'mail'
ostype = 'opensuse'
memory = 128
vcpus = 1
builder = 'linux'
vif = [ 'mac=00:16:3e:ab:00:0e, bridge=xenbr0' ]
localtime = 0
on_poweroff = 'destroy'
on_reboot = 'restart'
on_crash = 'restart'
extra = ' '
bootloader = '/usr/lib/xen/boot/domUloader.py'
bootargs = '--entry=hdb2:/boot/vmlinuz-xen,/boot/initrd-xen'
disk = [ 'phy:/dev/xenmachines/mail,hdb2,w',
'phy:/dev/xenmachines/mail-swap,hdb1,w' ]

Anyone have any idea what I'm missing, or suggestions as to how to
duplicate the configuration that I have been using with Xen 3.1?


- Ian

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.