[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Antwort: Re: [Xen-users] "'Invalid kernel', 'xc_dom_find_loader: no loader found\n" with new vanilla 2.6.23-rc8

Thanks Mark,

i've tried to boot your vmlinuz you've sent me and magic.. it works!
Kernel name is something with "*maw48*".
Summary the results:
- my Dom0 could boot 2.6.23-kernels
- xen 3.1.1-rc3 is capable of running 2.6.23-kernels
- one more point is, that you've compiled your kernel with 4.1.2 (Ubuntu), me with 4.1.1-21 (Debian)

Next, i'll try to compile a kernel (final 2.6.23) and try to strip/gzip it and try to boot.
Do you've set some non-default kernel settings to the kernel you've sent me?

PS: I'll keep at it since it will work with my configuration. :-)



"M.A. Williamson" <maw48@xxxxxxxxxxxxxxxx> schrieb am 11.10.2007 05:31:22:

> > At my linux-source directory, I've found one big vmlinux (45 MB). But this
> > file also gives me the same error message.
> That's odd; if Xen support was built in correctly I'd expect that to work.
> > If i do issue the following command, i do get the following (I've now
> > switched to 2.6.23-rc9):
> > debian:/home/linux-2.6.23-rc9# objdump -j __xen_guest -s ./vmlinux
> >
> > ./vmlinux:     file format elf32-i386
> My vmlinux gives me back this too...
> I think this is because the newer way of specifying XenLinux information is
> via elf notes.  The kernel.org merge omits legacy stuff.
> If you do readelf -n ./vmlinux you ought to see some Linux stuff come back.
> > >>What version of Xen are you running?
> >
> > I've installed the latest xen form testing. Until now: 3.1.1-rc3
> > Xen-tools: 3.8
> I'm running something ancient like 3.0.3.  I'm in the process of upgrading ;-)
> > So, at this time I think the build process from vanilla kernel isn't doing
> > the right thing.
> I tried the build with the 2.6.23 release and successfully booted it on my
> system.  I didn't bother giving it any disks, just ran it long enough to see
> some console output...
> Bear in mind that the mainline Linux implementation of Xen uses more /
> different common infrastructure and thus does things in different ways to the
> XenLinux the Xen project releases directly.  For instance, the console device
> used by mainline Linux to talk to the Xen console driver is hvc0 (a common
> hypervisor console device) rather than something Xen-specific.
> So even once you've got a kernel that Xen will start, you'll need to
> pass "console=hvc0" on the command line if you want it to talk to you during
> boot ;-)  This confused me for a bit tonight until I figured it out!
> Anyhow, the release of 2.6.23 should *definitely* give you a vmlinuxthat can
> boot.  Most of the size comes from symbols information, so if you strip the
> vmlinux it'll come down to a couple of megabytes first, anyhow.  I then
> gzipped mine and renamed it to vmlinuz, then successfully booted that
> (1.4Meg) kernel image under Xen - which worked fine too.  I'm not sure if
> there's a sanctioned way to get do the strip / gzip in the kernel build
> process, but doing it manually worked for me!
> Maybe you could try again, possibly with the 2.6.23 release, and we could try
> and debug any problems you see there?
> Cheers,
> Mark
> PS.  I've attached the vmlinuz I just built for reference.  This oneis built
> to use PAE, so if you have a non-PAE Xen then it won't boot.
> --
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.