[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen Install: "No filesystem could mount root, tried: ext2"

  • To: "Alasdair P Mclean" <mcleanap@xxxxxxxxxxxxx>
  • From: "Dan VerWeire" <dverweire@xxxxxxxxx>
  • Date: Wed, 17 Oct 2007 07:21:42 -0400
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Wed, 17 Oct 2007 04:22:29 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; b=T51phUYssBE7t7k4FYhDharE1orwUBynZxxNehTQswyLm2KzimwbNbvfXhHO/E0fz8NOg1s4XCkDyXEO84X5dLtta/R9JPJOxYwPMasFZvSYYNGsjMHxAzHFK2zOLAspwSfkwfi6YWNUJA7YK3YxMulyVNnN39RGMV6NKH7Oyf4=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi Ali,

I had the same error before. I tried two things and I'm not sure which one was the actual solution. I changed root=/dev/hda1 to root=/dev/hdb1 (or sdb1). The second thing I did was to compile in the drivers for my SATA and the Ext3 file system into the kernel. Where did you get your vmlinuz-2.6-xen from?



On 10/17/07, Alasdair P Mclean <mcleanap@xxxxxxxxxxxxx> wrote:

Hey guys, first time install, would appreciate any help.

On booting up the following error occurs: "No filesystem could mount root, tried: ext2. Kernel panic - not syncing: VFS unable to mount root fs on unknown-block(0,0)"

Like I say, any ideas very much appreciated. I've copied my menu.lst entry for Xen below if it's any use,


grub menu.lst:

title Xen 3.0 / XenLinux 2.6
  root (hd0,0)
  module /boot/xen-3.1.gz dom0_mem=262144 noreboot
  module /boot/vmlinuz-2.6-xen root=/dev/hda1 ro console=tty
  module /boot/initrd-2.6-xen

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.