[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen Install: "No filesystem could mount root, tried: ext2"

  • To: "Alasdair P Mclean" <mcleanap@xxxxxxxxxxxxx>
  • From: "Dan VerWeire" <dverweire@xxxxxxxxx>
  • Date: Wed, 17 Oct 2007 08:45:56 -0400
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Wed, 17 Oct 2007 05:46:46 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; b=j1UnolYvQjFRqDio8Ny+SRgC0Zf9ulXLj+FvDcAQQd90C5IBziS8Jv5w4VTSAcWMDa/Ks6DTzJAd86wsnWdw74uKToyusjNIRl8L5ZveATHmIQNdhVoijk4f00ffAlveFw96xEH2I7SvlpbMpM+/YR11y/9iyG+9bRswHqO37Cs=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hey Ali,

I built my domU kernel from Ubuntu sources so I'm not exactly sure what you need to do since your sources are from Xen. But I'll take a guess. If you go into your Xen source directory, probably something like /usr/src/xen- 3.0.3, there might be a sub directory called linux-2.6.18-xen. Go to that directory and try 'make menuconfig'. Then you will need to go to 'File systems' and press 'Y' next to each file system that you want to be compiled into the kernel. 'Y' will compile it in, 'M' will compile it as a module and 'N' will exclude it from being built. You may need to do the same thing for other things found in 'Device Drivers' depending on your hardware setup.

To be honest, I didn't know what needed to be compiled in specifically, so I just tried a bunch of logical options until it worked. If you have a working kernel that you can boot the system with, you may want to try running 'lspci' to get a list of devices such as your IDE, SATA or SCSI and try to find a driver that might match that device and compile it in.

Hope this helps,


On 10/17/07, Alasdair P Mclean <mcleanap@xxxxxxxxxxxxx> wrote:

Hey Dan,

The vmlinuz-2.6-xen I compiled myself from Xen 3.0.3 source (although I have tried the pre-compiled one and it has the same problem).

Could you tell me how I can go about compiling the drivers into the kernel please?


-----Original Message-----
From: Dan VerWeire [mailto:dverweire@xxxxxxxxx]
Sent: Wed 10/17/2007 12:21 PM
To: Alasdair P Mclean
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Xen Install: "No filesystem could mount root, tried: ext2"

Hi Ali,

I had the same error before. I tried two things and I'm not sure which one
was the actual solution. I changed root=/dev/hda1 to root=/dev/hdb1 (or
sdb1). The second thing I did was to compile in the drivers for my SATA and
the Ext3 file system into the kernel. Where did you get your



On 10/17/07, Alasdair P Mclean <mcleanap@xxxxxxxxxxxxx> wrote:
>  Hey guys, first time install, would appreciate any help.
> On booting up the following error occurs: "No filesystem could mount root,
> tried: ext2. Kernel panic - not syncing: VFS unable to mount root fs on
> unknown-block(0,0)"
> Like I say, any ideas very much appreciated. I've copied my menu.lst entry
> for Xen below if it's any use,
> Cheers,
> Ali
> grub menu.lst:
> title Xen 3.0 / XenLinux 2.6
>   root (hd0,0)
>   module /boot/xen-3.1.gz dom0_mem=262144 noreboot
>   module /boot/vmlinuz-2.6-xen root=/dev/hda1 ro console=tty
>   module /boot/initrd-2.6-xen
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.